Переключение на Главную Страницу Страницы: [1] 2 3 ... 9 ОтправитьПечать
Закрытая тема icpp 3.2.3.x (число прочтений - 80253 )
trad
1c++ power user
1c++ donor
1c++ moderator
Отсутствует



Сообщений: 3014
Местоположение: Киров
Зарегистрирован: 23. Мая 2006
Пол: Мужской
icpp 3.2.3.x
03. Ноября 2010 :: 08:59
 
ipp 3.2.3.1
[+] 4487 Реализован глобальный поиск в ТП

Поиск доступен сразу после загрузки новой версии ВК.

События:
ПриФорматированииСтроки / OnRowFormat
ПриКомандеБуфераОбмена / OnClipboard
ПриПоиске / OnFind
ПриДиалогеПоиска / OnFindDialog

Объект:
ФорматЯчейки

Структура:
ГлобальныеДанныеПоиска



Другие изменения, опубликованные в этой ветке

icpp 3.2.3.2 2010-11-11
Работа класса 1cpp.Delegate была нарушена в рабочих сборках
3.2.2.8
3.2.3.1
Восстановлена в
3.2.3.2

http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/31#31


icpp 3.2.3.3 2010-11-16
[-] По "Ctrl+Alt+F" вылезает окошко поиска
http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/37#37


icpp 3.2.3.4 2010-11-18
[-] 4512 - ТП: потеря значений шапки и подвала при изменении видимости колонки
http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/39#39


icpp 3.2.3.6 2010-12-08
[-] 4514 - ТП: UpdateLock может нарушать логику обновления данных ТП при изменении данных в событии ПриКонтекстномМеню
[+] 4517 - EV: Добавить событие ПриОтменеРедактированияЗначения
[+] 4518 - EV: Добавить ФСО в событие ПриРедактированииЗначения
[-] 4519 - EV: Прокрутка ТП колесом возможна при активном окне редактирования

http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/40#40


icpp 3.2.3.7 2010-12-09
[!] 4522 - OOP: AV при передаче пустого значения в метод с неопределенным числом параметоров
http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/46#46


icpp 3.2.3.8 2010-12-10
[!] 4523 - EV: AV при завершении редактирования в случае невидимости родительского ТП
http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/54#54


icpp 3.2.3.9 2011-01-26
[!] 4527 - ENH: Добавить поддержку события ПослеЗаписи для элементов справочников
Примечание:
Для версии icpp 3.2.3.9 поддерживаются релизы 1С: 18,19,20,21,23,25,26,27.

http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/56#56


icpp 3.2.3.10 2011-02-11
[+] 4528 - ТП: Добавить событие ПослеРедактированияЗначения
[-] 4523 - EV: AV при завершении редактирования в случае невидимости родительского ТП (reopened)

http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/65#65


icpp 3.2.3.11 2011-03-30
[-] 4531 В присоединенной ИБ в ВТ не правильно формируется граница за ТА
http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/75#75


icpp 3.2.3.12 2011-04-11
[-] 4532 EV: AV при отмене редактирования значения при появлении верт. скроллера
http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/79#79


icpp 3.2.3.13 2011-06-01
[+] 4536 - ENH: Добавить функции Beep / MessageBeep в класс "Система"
http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/83#83


icpp 3.2.3.14 2011-06-14
(*) 4500 - Метод ИТЗ ВыгрузитьСтроку не очищает СпиокЗначений (исправлена документация)
[-] 4535 - Некорректная работа парсера
[-] 4538 - ИТ: обеспечить возможность сохранения / восстановления итераторов

http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/89#89


icpp 3.2.3.15 2011-06-15
[+] 4539 - ТП: Добавить возможность редактирования заголовка
[+] 4540 - ТП: Добавить событие Выбор для заголовка

http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/91#91


icpp 3.2.3.16 2011-08-11
[-] 4520 - не работали Ctrl+C Ctrl+V в полях ввода при наличии ТП на форме в модальном режиме.
http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/98#98


icpp 3.2.3.17 2011-12-01
[-] 4543 - ТП: AV при попытке редактирования несуществующих шапки или подвала
[!] 4544 - ТП: AV при изменении размеров окна ТП в режиме редактирования
[+] 4545 - ENH: Добавить коллекциям функцию ВГраница()

http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/108#108


icpp 3.2.3.18 2012-01-17
[-] 4546 - не убираются пробелы слева при использовании формата для колонки если поставщик данных - ИТ
http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/112#112


icpp 3.2.3.19 2012-01-24
[-] 4547 - Форма: События формы вызываются многократно
http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/113#113


icpp 3.2.3.20 2012-01-24
[-] 4551 - ТП: события мыши могут не отрабатывать для шапки или подвала
http://www.1cpp.ru/forum/YaBB.pl?num=1288774760/118#118
« Последняя редакция: 20. Марта 2012 :: 19:12 - kms »  

icpp3231_20101103.rar ( 788 KB | Загрузки )

1&&2&&3
Наверх
IP записан
 
Dmitry The Wing
God Member
*****
Отсутствует


1C++ rocks!

Сообщений: 839
Местоположение: Где-то в Сибири
Зарегистрирован: 18. Августа 2009
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #1 - 03. Ноября 2010 :: 09:10
 
trad писал(а) 03. Ноября 2010 :: 08:59:
cpp 3.2.3.1

а где 3.2.3.0?
  
Наверх
 
IP записан
 
trad
1c++ power user
1c++ donor
1c++ moderator
Отсутствует



Сообщений: 3014
Местоположение: Киров
Зарегистрирован: 23. Мая 2006
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #2 - 03. Ноября 2010 :: 09:21
 
несколько цитат:

Цитата:
Поиск должен работать сразу и без доп.настройки при загрузке новой ВК. Для этого должно отрабатывать событие ПриВыводеСтроки для получения текстовых представлений ячеек.

Но есть возможность "облегчить" этот процесс. Для этого есть специальное событие ПриФорматированииСтроки. Если это событие реализовано, то ПриВыводеСтроки при поиске не возбуждается.


Нагляднее видно по коду:
Код
Выбрать все
//В части работы над текстом, коллекции ячеек (из ОформлениеЯчейки и из ФорматЯчейки)
//специально сделаны одинаковыми. Чтобы был применим некоторый полиморфизм.
Процедура ФорматированиеЯчеек(Ячейки, Данные)
	//Общая процедура обработки текста ячеек. Для вывода и для поиска.
	Ячейки.Кол2.Текст=Формат(Данные.Кол2,"ЧПДС");
	Ячейки.Кол4.Текст="123473857";
КонецПроцедуры

Процедура ПолеПриВыводеСтроки(ТП, Оформление, Данные)
	ФорматированиеЯчеек(Оформление.Ячейки,Данные);
КонецПроцедуры

//Новое событие
Процедура ПолеПриФорматированииСтроки(ТП, ФорматСтроки, Данные)
	//ФорматСтроки - фиксированная коллекция (похожая на коллекцию ОформлениеСтроки::Ячейки)
	//состоит из объектов типа ФорматЯчейки
	//есть свойство ФорматЯчейки.Текст
	//есть метод ФорматЯчейки.УстановитьТекст()

	ФорматированиеЯчеек(ФорматСтроки, Данные);
КонецПроцедуры
 



Еще события. Возбуждаемые самим поиском и вызовом диалога

Код
Выбрать все
//Новое событие
Процедура ПолеПриПоиске(ТП, ДанныеПоиска, ФСО)
	//Сообщить(ДанныеПоиска.Значение);
	//Сообщить(ДанныеПоиска.Строка);
	//Сообщить(ДанныеПоиска.Назад);
	//Сообщить(ДанныеПоиска.УчитыватьРегистр);
	//Сообщить(ДанныеПоиска.ПоОднойКолонке);
	//ФСО=0;
	//можно подменить алгоритм поиска
КонецПроцедуры
 


Код
Выбрать все
//Новое событие
Процедура ПолеПриДиалогеПоиска(ТП, ДанныеПоиска, ФСО)
	//Сообщить(ДанныеПоиска.Значение);
	//Сообщить(ДанныеПоиска.Строка);
	//Сообщить(ДанныеПоиска.Назад);
	//Сообщить(ДанныеПоиска.УчитыватьРегистр);
	//Сообщить(ДанныеПоиска.ПоОднойКолонке);
	//ФСО=0;
	//можно подменить диалог поиска
КонецПроцедуры
 




Цитата:
Ну и прицепом - небольшой бонус.

ТП теперь не безразличны команды Copy, Paste, M, M+, M-.
Copy - копирует в буфер обмена текст из тек.ячейки.
M - копирует в буфер, M+ - прибавляет, а M- - вычитает число полученное путем приведения из текста тек.ячейки.
Все команды возбуждают событие ПриКомандеБуфераОбмена(Команда, Стр, ФСО)
где Команда: 0 - Copy, 1 - Paste, 2 - M, 3 - M+, 4 - M-.
Стр - копируемый или вставляемый текст.
ФСО = 0 - отмена действия команды.

Код
Выбрать все
Процедура ПолеПриКомандеБуфераОбмена(ТП, Команда, Стр, ФСО)
     Если Команда=0 Тогда
	     Сообщить("Copy: "+Стр);
     ИначеЕсли Команда=1 Тогда
	     Сообщить("Paste: "+Стр);
     ИначеЕсли Команда=2 Тогда
	     Сообщить("M: "+Стр);
     ИначеЕсли Команда=3 Тогда
	     Сообщить("M+: "+Стр);
     ИначеЕсли Команда=4 Тогда
	     Сообщить("M-: "+Стр);
     КонецЕсли;
     //ФСО=0;
КонецПроцедуры 

  

1&&2&&3
Наверх
IP записан
 
trad
1c++ power user
1c++ donor
1c++ moderator
Отсутствует



Сообщений: 3014
Местоположение: Киров
Зарегистрирован: 23. Мая 2006
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #3 - 03. Ноября 2010 :: 09:24
 
и еще цитата
Цитата:
//взаимодействие с глобальным поиском не удается сделать релизонезависимым,
//поэтому "точки" подключения к глобальным данным указываем явно
//поддерживаются релизы v7
//15,18,19,20,21,24,25,26,27
  

1&&2&&3
Наверх
IP записан
 
trad
1c++ power user
1c++ donor
1c++ moderator
Отсутствует



Сообщений: 3014
Местоположение: Киров
Зарегистрирован: 23. Мая 2006
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #4 - 03. Ноября 2010 :: 09:25
 
Dmitry The Wing писал(а) 03. Ноября 2010 :: 09:10:
а где 3.2.3.0?

нигде. это неопубликованный релиз.
  

1&&2&&3
Наверх
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #5 - 03. Ноября 2010 :: 18:08
 
Дим, я очень рад что этот релиз наконец вышел. Хочу извинится за постоянное отсутствие времени и возможности проверить. Но все хорошо, что хорошо кончается. Спасибо тебе очень большое.

Пы.сы. тут небольшая революция, а общественность спокойна  Круглые глаза
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
zk96
Senior Member
****
Отсутствует


1C++ rocks!

Сообщений: 320
Местоположение: Киев
Зарегистрирован: 15. Ноября 2009
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #6 - 03. Ноября 2010 :: 18:41
 
trad писал(а) 03. Ноября 2010 :: 08:59:
cpp 3.2.3.1
  • 4487 Реализован глобальный поиск в ТП

События:
ПриФорматированииСтроки / OnRowFormat
ПриКомандеБуфераОбмена / OnClipboard
ПриПоиске / OnFind
ПриДиалогеПоиска / OnFindDialog

Объект:
ФорматЯчейки

Структура:
ГлобальныеДанныеПоиска


Поиск доступен сразу после загрузки новой версии ВК.

Попробовал.
КЛАСС!!!
  
Наверх
 
IP записан
 
pavel_tr
Senior Member
****
Отсутствует



Сообщений: 274
Местоположение: Казань
Зарегистрирован: 14. Октября 2006
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #7 - 03. Ноября 2010 :: 21:42
 
Спасибо большое, давно не хватало!
  
Наверх
 
IP записан
 
JohnyDeath
1c++ power user
1c++ donor
Отсутствует



Сообщений: 3050
Местоположение: Волгоград
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #8 - 04. Ноября 2010 :: 11:29
 
Дима, большое спасибо! Я и мои пользователи уже и не надеялись увидеть такое в ТП Подмигивание
  
Наверх
 
IP записан
 
pavlo
1c++ donor
1c++ power user
Отсутствует



Сообщений: 712
Местоположение: г. Новосибирск
Зарегистрирован: 10. Ноября 2006
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #9 - 09. Ноября 2010 :: 04:17
 
ну просто нет слов, супер спасибо тебе великое Дим  Очень довольный
  

1с++     3.2.4.1
Formex  2.0.5.99b
Наверх
IP записан
 
trad
1c++ power user
1c++ donor
1c++ moderator
Отсутствует



Сообщений: 3014
Местоположение: Киров
Зарегистрирован: 23. Мая 2006
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #10 - 09. Ноября 2010 :: 06:27
 
to all
и что. неужели все работает. и вопросов нет никаких Озадачен
  

1&&2&&3
Наверх
IP записан
 
Z1
God Member
*****
Отсутствует


I Love YaBB 2!

Сообщений: 2906
Местоположение: Москва
Зарегистрирован: 26. Мая 2006
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #11 - 09. Ноября 2010 :: 07:28
 
trad писал(а) 09. Ноября 2010 :: 06:27:
to all
и что. неужели все работает. и вопросов нет никаких Озадачен

пока не проверял. до конца недели попробую нов версию.
  
Наверх
 
IP записан
 
pavlo
1c++ donor
1c++ power user
Отсутствует



Сообщений: 712
Местоположение: г. Новосибирск
Зарегистрирован: 10. Ноября 2006
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #12 - 09. Ноября 2010 :: 08:15
 
trad писал(а) 09. Ноября 2010 :: 06:27:
to all
и что. неужели все работает. и вопросов нет никаких Озадачен


с процедурами не возился, так все пашет, один раз было в отладчике сказало Буфер обмена занят при попытке скопировать (до этого игрался с ТП)  уж не знаю что, но перезаход в 1с все решил и повторить проблему не удалось!
  

1с++     3.2.4.1
Formex  2.0.5.99b
Наверх
IP записан
 
kms
1c++ power user
1c++ moderator
Отсутствует


я хочу, чтоб сюда проложили
дорогу оттуда...

Сообщений: 4631
Зарегистрирован: 19. Мая 2006
Re: icpp 3.2.3.x
Ответ #13 - 09. Ноября 2010 :: 09:42
 
trad писал(а) 09. Ноября 2010 :: 06:27:
to all
и что. неужели все работает. и вопросов нет никаких Озадачен

Ну как же.
Как всегда - вопрос один: почему нет вопросов?

Улыбка
  

De quelle planète es-tu?
Наверх
 
IP записан
 
Dmitry The Wing
God Member
*****
Отсутствует


1C++ rocks!

Сообщений: 839
Местоположение: Где-то в Сибири
Зарегистрирован: 18. Августа 2009
Пол: Мужской
Re: icpp 3.2.3.x
Ответ #14 - 09. Ноября 2010 :: 10:01
 
kms писал(а) 09. Ноября 2010 :: 09:42:
Ну как же.
Как всегда - вопрос один: почему нет вопросов?
Улыбка

Потому что пока проблем не обнаружено - все, что пользуется - работает... сбоев не замечено...
  
Наверх
 
IP записан
 
Переключение на Главную Страницу Страницы: [1] 2 3 ... 9
ОтправитьПечать