Переключение на Главную Страницу Страницы: 1 [2]  ОтправитьПечать
Горячая тема (более 10 ответов) Как "распознать" класс? (число прочтений - 1987 )
es3000
God Member
*****
Отсутствует



Сообщений: 531
Зарегистрирован: 10. Июля 2006
Re: Как "распознать" класс?
Ответ #15 - 02. Июня 2019 :: 08:20
Печать  
Что скажете, уважаемые разработчики 1С++?
Можно это доработать?
  
Наверх
ICQ  
IP записан
 
MadDAD
Junior Member
**
Отсутствует


1C++ rocks!

Сообщений: 22
Зарегистрирован: 17. Ноября 2015
Re: Как "распознать" класс?
Ответ #16 - 03. Июня 2019 :: 11:21
Печать  
es3000 писал(а) 30. Мая 2019 :: 13:00:
А контекст формы или документа надо отсеивать?



Думаю не надо. Это ведь аггрегатные типы. Вообще если бы мне нужно было, я бы уже давно взял отладчик и проверил разные варианты самостоятельно.

Думаю что сейчас уже никто не будет добавлять методы к информатору.
Но никто не запрещает создать класс-наследник от Информатора и реализовать там такую проверку Улыбка
  
Наверх
 
IP записан
 
antowski
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 1
Зарегистрирован: 08. Декабря 2019
Re: Как "распознать" класс?
Ответ #17 - 08. Декабря 2019 :: 19:32
Печать  
Вот пример кода для проверки информатором:

Код (C++)
Выбрать все
Функция ЭтоЭкземплярКОП(Объект)

	Информатор = СоздатьОбъект("Информатор");
	Возврат Информатор.МетодСуществует(Объект, "ПолучитьБазовыйКласс");

КонецФункции // ЭтоЭкземплярКОП

Процедура Сформировать()

	Привязка = СоздатьОбъект("Общие.Форма.Привязка");
	ТабЗнач = СоздатьОбъект("ТаблицаЗначений");

	Если ЭтоЭкземплярКОП(Привязка) = 1 Тогда
		Сообщить("Экземпляр класса ""Общие.Форма.Привязка"" - КОП");
	Иначе
		Сообщить("Экземпляр класса ""Общие.Форма.Привязка"" - не КОП");
	КонецЕсли;

	Если ЭтоЭкземплярКОП(ТабЗнач) = 1 Тогда
		Сообщить("Таблица значений - КОП");
	Иначе
		Сообщить("Таблица значений - не КОП");
	КонецЕсли;

КонецПроцедуры
 



Сообщения в окне:
Цитата:
Экземпляр класса "Общие.Форма.Привязка" - КОП
Таблица значений - не КОП
  
Наверх
 
IP записан
 
Переключение на Главную Страницу Страницы: 1 [2] 
ОтправитьПечать