Переключение на Главную Страницу Страницы: 1 [2] 3 4  ОтправитьПечать
Очень популярная тема (более 25 ответов) ПриОтжатииКнопкиКлавиатуры проблему не решила (число прочтений - 11616 )
vip
1c++ power user
Отсутствует



Сообщений: 1570
Зарегистрирован: 19. Мая 2006
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #15 - 06. Июля 2006 :: 09:14
Печать  
Цитата:
Спасибо Vip за ссылку, я видел этот тест, но он не проливает свет на систему. Так что же это такое, к чему относится что может и с чем ее едят?

Почему же не проливает?
"В сегодняшней ночной сборке добавлен механизм активации элементов диалога из ФОРМУЛ ЭЛЕМЕНТОВ ДИАЛОГА."
Попробуй активизировать штатно один реквизит из другого (не кнопки).
  
Наверх
ICQ  
IP записан
 
КилоГрамм
Senior Member
****
Отсутствует


Таити, Таити...

Сообщений: 434
Зарегистрирован: 14. Июня 2006
Пол: Мужской
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #16 - 06. Июля 2006 :: 09:24
Печать  
Цитата:
Почему же не проливает?

Я о опять о том, что документация хронически отстает от разаработок, а тем паче от ночных сборок.
  

Константин
Наверх
 
IP записан
 
КилоГрамм
Senior Member
****
Отсутствует


Таити, Таити...

Сообщений: 434
Зарегистрирован: 14. Июня 2006
Пол: Мужской
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #17 - 06. Июля 2006 :: 09:27
Печать  
Цитата:
Сервис.ЭмулироватьКлавиатуру("{ENTER}", 0, );
Система = СоздатьОбъект("Система");
Система.РазрешитьАктивацию();
Система.Активизировать("Реквизит");
Сервис.ЭмулироватьКлавиатуру("{END}", 0
Метод эмуляции нажатия клавиши применять в процедурах ПриНажатии и ПриОтжатии кнопки клавиатуры недопустимо. Что делать будем?
  

Константин
Наверх
 
IP записан
 
Arta
1c++ power user
Отсутствует



Сообщений: 2537
Местоположение: Нижний Новгород
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #18 - 06. Июля 2006 :: 09:54
Печать  
Есть нюанс, во внешней обработке открытой модально - не работает ПриНажатииКнопкиКлавиатуры

Альф, тогда так ничего и не сказал по этому поводу Печаль
  
Наверх
 
IP записан
 
КилоГрамм
Senior Member
****
Отсутствует


Таити, Таити...

Сообщений: 434
Зарегистрирован: 14. Июня 2006
Пол: Мужской
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #19 - 06. Июля 2006 :: 10:42
Печать  
Цитата:
Альф, тогда так ничего и не сказал по этому поводу

С этой проблемой я к нему давно пристаю. Собственно просьба сделать ПриОтжатииКнопкиКлавиатуры была продиктована именно ей (проблемой). Спаисбо АльФу, процедура есть, но проблема осталась. Я по свей косности думал что метод при отжатии будет как-бы финалом манипуляций с клавой и позволит получить значение текста в поле ввода.
  

Константин
Наверх
 
IP записан
 
Arta
1c++ power user
Отсутствует



Сообщений: 2537
Местоположение: Нижний Новгород
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #20 - 06. Июля 2006 :: 10:45
Печать  
Эээ... при отжатии в монопольном окне также не работает. Или это какая то особая сборка?
  
Наверх
 
IP записан
 
vip
1c++ power user
Отсутствует



Сообщений: 1570
Зарегистрирован: 19. Мая 2006
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #21 - 06. Июля 2006 :: 12:16
Печать  
vip писал(а) 06. Июля 2006 :: 08:53:
Цитата:
Да, только у меня гораздо в более извращенном варианте. Единственный минус - попытаешься отредактировать строку посередине и курсор опять будет в конце. Но отредактируется

Поделись извратом.

arta, намекни хоть принцип, если решил.
  
Наверх
ICQ  
IP записан
 
vip
1c++ power user
Отсутствует



Сообщений: 1570
Зарегистрирован: 19. Мая 2006
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #22 - 06. Июля 2006 :: 19:00
Печать  
vip писал(а) 06. Июля 2006 :: 12:16:
vip писал(а) 06. Июля 2006 :: 08:53:
Цитата:
Да, только у меня гораздо в более извращенном варианте. Единственный минус - попытаешься отредактировать строку посередине и курсор опять будет в конце. Но отредактируется

Поделись извратом.

arta, намекни хоть принцип, если решил.

Или ты пошутил?
  
Наверх
ICQ  
IP записан
 
Arta
1c++ power user
Отсутствует



Сообщений: 2537
Местоположение: Нижний Новгород
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #23 - 06. Июля 2006 :: 20:24
Печать  
Цитата:
Метод эмуляции нажатия клавиши применять в процедурах ПриНажатии и ПриОтжатии кнопки клавиатуры недопустимо. Что делать будем?


Допустимо   Язык
  

SendKeys.ert ( 28 KB | Загрузки )
Наверх
 
IP записан
 
vip
1c++ power user
Отсутствует



Сообщений: 1570
Зарегистрирован: 19. Мая 2006
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #24 - 06. Июля 2006 :: 20:32
Печать  
Гы Улыбка
Работает
  
Наверх
ICQ  
IP записан
 
vip
1c++ power user
Отсутствует



Сообщений: 1570
Зарегистрирован: 19. Мая 2006
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #25 - 06. Июля 2006 :: 20:36
Печать  
Перем ЗащитаОтАльфа;  Очень довольный

Ну что, попытаться перейти на раздельные 1Cpp и FormEx?
А ночная сборка без FormEx тоже собирается автоматически?
  
Наверх
ICQ  
IP записан
 
Arta
1c++ power user
Отсутствует



Сообщений: 2537
Местоположение: Нижний Новгород
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #26 - 06. Июля 2006 :: 21:09
Печать  
Думаю что пока не стоит...
Хотя для себя я решил таким образом:
ГМ:
Код
Выбрать все
Если (ИмяПользователя() = "Пупкин") И (Константа.Тест = Да) Тогда

	Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "test\Formex.dll") = 0 Тогда
		Предупреждение("Неудачная попытка загрузить formex.dll");
	КонецЕсли;

	Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "test\1CPP.dll") = 0 Тогда
		Предупреждение("Неудачная попытка загрузить 1cpp.dll");
	КонецЕсли;

Иначе

	Если ЗагрузитьВнешнююКомпоненту("1CPP.dll") = 0 Тогда
		Предупреждение("Неудачная попытка загрузить 1CPP.dll");
	КонецЕсли;
 



Класс по иниту ТП и Активиксов:
Код
Выбрать все
Функция	СоздатьЭлементУправления(Конт, Объект, Реквизит) Экспорт

	Если (ИмяПользователя() = "Пупкин") И (Константа.Тест = Да) Тогда
		_Форма = СоздатьОбъект("Форма");
		_Форма.УстановитьФорму(Конт.Форма);
		Возврат(_Форма.СоздатьЭлементУправления(Объект, Реквизит));
	Иначе
		АтрФормы = СоздатьОбъект("АтрибутФормы");
		АтрФормы.УстановитьАтрибут(Конт.Форма, Реквизит);
		Если АтрФормы.Тип = 3 Тогда // Кнопка
			Об = АтрФормы.СоздатьЭлементУправления(Объект);
			Возврат Об;
		ИначеЕсли АтрФормы.Тип = 1 Тогда // Текст
			Об = АтрФормы.СоздатьЭлементУправления(Объект);
			Возврат Объект;
		Иначе
			Сообщить("Не получилось " + АтрФормы.ТипЗначенияСтр());
		КонецЕсли;
	КонецЕсли;
КонецФункции
 



Сам же инит ТП и Активиксов так:
Код
Выбрать все
Служебное = СоздатьОбъект("Служебное") // вышеприведенный класс
Статус = Служебное.СоздатьЭлементУправления(Конт, СоздатьОбъект("Активикс"), "СтатусБар");
или
ТабличноеПолеСобытия = Служебное.СоздатьЭлементУправления(Конт, СоздатьОбъект("ТабличноеПоле"), "ТабличноеПолеСобытия");
 



На переходный период, на время тестов буду работать на новых бетах. Все остальные на 2.0.3.0
  
Наверх
 
IP записан
 
vip
1c++ power user
Отсутствует



Сообщений: 1570
Зарегистрирован: 19. Мая 2006
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #27 - 07. Июля 2006 :: 03:28
Печать  
Наверное, твое решение правильное (о выборочной загрузке ВК).
Попробую и я так.
  
Наверх
ICQ  
IP записан
 
КилоГрамм
Senior Member
****
Отсутствует


Таити, Таити...

Сообщений: 434
Зарегистрирован: 14. Июня 2006
Пол: Мужской
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #28 - 07. Июля 2006 :: 11:42
Печать  
Код
Выбрать все
ЗащитаОтАльфа=1; 

Вот от него я и не защитился вовремя. Теперь работает. Спасибо.
  

Константин
Наверх
 
IP записан
 
simply
God Member
*****
Отсутствует


Мечта: избавиться от 1С

Сообщений: 573
Местоположение: Киев
Зарегистрирован: 31. Декабря 2008
Пол: Мужской
Re: ПриОтжатииКнопкиКлавиатуры проблему не решила
Ответ #29 - 21. Февраля 2011 :: 12:20
Печать  
Arta писал(а) 06. Июля 2006 :: 20:24:
Цитата:
Метод эмуляции нажатия клавиши применять в процедурах ПриНажатии и ПриОтжатии кнопки клавиатуры недопустимо. Что делать будем?


Допустимо   Язык

Подскажите, появилось более красивое решение?
Или все также, через: "Перем ЗащитаОтАльфа"? Подмигивание
  
Наверх
IP записан
 
Переключение на Главную Страницу Страницы: 1 [2] 3 4 
ОтправитьПечать