Переключение на Главную Страницу Страницы: 1 [2]  ОтправитьПечать
Горячая тема (более 10 ответов) Аналог "ПослеЗаписи()" есть в природе? (число прочтений - 9101 )
Arta
1c++ power user
Отсутствует



Сообщений: 2537
Местоположение: Нижний Новгород
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Аналог "ПослеЗаписи()" есть в природе?
Ответ #15 - 24. Августа 2006 :: 19:24
Печать  
sedmin писал(а) 24. Августа 2006 :: 19:14:
Не понимаю, какие проблемы?

Проблема есть... Мне надо на новом документе, не выходя из него, получить его ID.
Например засунуть документ в лог. Да мало ли что может понадобиться...
  
Наверх
 
IP записан
 
sedmin
1c++ developer
Отсутствует


I Hate Fat YaBB 2!

Сообщений: 862
Зарегистрирован: 24. Мая 2006
Re: Аналог "ПослеЗаписи()" есть в природе?
Ответ #16 - 24. Августа 2006 :: 19:46
Печать  
Так получай. В ПриЗакрытии() он уже будет. Запись произойдет между ПриЗаписи() и ПриЗакрытии().

А пока не записал - его физически нет, неизвестно какой он будет. Если ты форму не хочешь закрывать, то сделай кнопку "Записать", тогда ИД появится.

Кстати, можешь просто написать

Код
Выбрать все
Процедура ПриЗакрытии()
  Если Выбран()=1 Тогда
    ЧтоНибудьСделать();
  КонецЕсли;
КонецПроцедуры 

  
Наверх
 
IP записан
 
Arta
1c++ power user
Отсутствует



Сообщений: 2537
Местоположение: Нижний Новгород
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Аналог "ПослеЗаписи()" есть в природе?
Ответ #17 - 25. Августа 2006 :: 09:13
Печать  
Нет. Мне надо иметь ID либо в ПриЗаписи, либо новую процедуру послезаписи.

В ПриЗакрытии у меня сейчас работает, но многого не могу сделать.

  
Наверх
 
IP записан
 
steban
1c++ developer
Отсутствует


#define sizeof(x) rand()

Сообщений: 787
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Аналог "ПослеЗаписи()" есть в природе?
Ответ #18 - 25. Августа 2006 :: 09:19
Печать  
Может это:
Обход блокировок в открытых формах документов и справочников
тебе подойдет?
romix, например для постобработки использует внешние события.
  

int getRandomNumber()&&{&&  return 4; //chosen by fair dice roll&&         //guaranteed to be random&&}
Наверх
 
IP записан
 
Arta
1c++ power user
Отсутствует



Сообщений: 2537
Местоположение: Нижний Новгород
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Аналог "ПослеЗаписи()" есть в природе?
Ответ #19 - 25. Августа 2006 :: 09:57
Печать  
Да Альф уже предложил решение, просто в ПриЗаписи делать Записать() Улыбка
  
Наверх
 
IP записан
 
КилоГрамм
Senior Member
****
Отсутствует


Таити, Таити...

Сообщений: 434
Зарегистрирован: 14. Июня 2006
Пол: Мужской
Re: Аналог "ПослеЗаписи()" есть в природе?
Ответ #20 - 09. Сентября 2006 :: 08:04
Печать  
Я в таких карявых случаях пишу в проце ПриЗакрытии: Если Выбран() = 1 Тогда ОткрытьФорму(Справочник/Журнал,Параметры). А в Форме спика Справочника/Журннала пишу все остальное в проце ПриПовторномОткрытии(). Конечно форма спика уже открыта
  

Константин
Наверх
 
IP записан
 
trdm
1c++ power user
qt1l developer
1c++ moderator
Отсутствует



Сообщений: 2342
Местоположение: г. Ростов-на-Дону
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Аналог "ПослеЗаписи()" есть в природе?
Ответ #21 - 16. Сентября 2006 :: 08:02
Печать  
Набрел на такой текст в классе:
Код
Выбрать все
Функция ЭмулироватьПослеЗаписи( псЭлемент ) Экспорт
	ЗначВозврата		= 0;
	м_ПерваяЗапись		= 0;
	СтатусВозвратаСтарый= СтатусВозврата();
	Если псЭлемент.Выбран() = 0 Тогда
		СтатусВозврата(0);
		Попытка
			псЭлемент.Записать();
			м_ПерваяЗапись = 1;
			Сообщить("Записан успешно.....");
			ЗначВозврата = 1;
		Исключение
			ЗначВозврата = 0;
			Сообщить(ОписаниеОшибки(),"!!!");
		КонецПопытки;
		СтатусВозврата(СтатусВозвратаСтарый);
	КонецЕсли;
	Возврат ЗначВозврата;
КонецФункции // ЭмулироватьПослеЗаписи()

 

  
Наверх
IP записан
 
Переключение на Главную Страницу Страницы: 1 [2] 
ОтправитьПечать