Переключение на Главную Страницу Страницы: 1 [2] 3 4 ... 66 ОтправитьПечать
Очень популярная тема (более 25 ответов) Colorer for Openconf - обсуждения (число прочтений - 395508 )
ssn1978
YaBB Newbies
*
Отсутствует


I Love YaBB 2!

Сообщений: 1
Зарегистрирован: 05. Августа 2006
Re: Colorer for Openconf
Ответ #15 - 21. Февраля 2007 :: 07:47
Печать  
Да уж, весч стоящая, автору огромный респект

Пожелание: Автоматическое разворачивание всех процедур перед сохранением конфигурации.

Вопрос: Не понял почему у меня дома ругается, если сохраняешь конфу при свернутых процедурах,
а на работе поставил и сохраняет без вопросов при свернутых процедурах, от чего зависит?
  
Наверх
 
IP записан
 
The gray Cardinal
Full Member
***
Отсутствует



Сообщений: 159
Зарегистрирован: 17. Июня 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #16 - 21. Февраля 2007 :: 08:17
Печать  
Если не устанавливать скрипт, проблемы с прорисовкой (WinXP SP2, 7.70.025). Так и должно быть?
  

screen.JPG ( 23 KB | Загрузки )
screen.JPG
Наверх
www  
IP записан
 
bsa
Junior Member
**
Отсутствует


Не профессионал но и не
любитель...

Сообщений: 27
Местоположение: Одесса
Зарегистрирован: 20. Июня 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #17 - 21. Февраля 2007 :: 08:25
Печать  
Суперная вещь, отлично!
Внесу и свои предложения:
1. Выделение по SelectInnerBlock - думаю имело бы смысл выделять не то, что находится между Если-КонецЕсли и Цикл-КонецЦикла (т.е. включая и условия), а только строки в рамках этих конструкций (исключая условия). Например в коде:
Код
Выбрать все
Если а=1 Тогда
   а = 2;
КонецЕсли; 


выделять только
Код
Выбрать все
а = 2; 


2. Сейчас подстветка конструкций Если/Цикл и т.д. происходит всегда при позиционировании курсора на любом из ключевых слов конструкции. Если "пройти" курсором вверх или вниз по тексту, где есть эти конструкции, все они автоматом подствечиваются и текст начинает "рябить".
а) Хотелось бы иметь возможность "сбросить" все подстветки. Может быть реализовать для этого отдельный метод.
б) Как вариант - сделать автоматическую подстветку этих конструкций опциональной.
  
Наверх
ICQ  
IP записан
 
trdm
1c++ power user
qt1l developer
1c++ moderator
Отсутствует



Сообщений: 2343
Местоположение: г. Ростов-на-Дону
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #18 - 21. Февраля 2007 :: 08:57
Печать  
"Пропадают" инстансы. Вжик и нету предприятия или конфигуратора.. ((
Еще кое-что: при подсветке скобок непонятно где курсор стоит.
Приходится ждать мигания курсора что-бы понять где он.
Да в принципе в любой подсвеченной инструкции.
  
Наверх
IP записан
 
The gray Cardinal
Full Member
***
Отсутствует



Сообщений: 159
Зарегистрирован: 17. Июня 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #19 - 21. Февраля 2007 :: 10:49
Печать  
Замеченные неприятности:

1. Вертикальная белая черта в gutter'е в разделе объявления переменных в глобальнике то прорисовывается, то нет (закономерности не понял).

2. Если парная текущей закрывающая/открывающая "скобка" (типа "Пока" или "КонецЦикла" и т.п.) находится за пределами видимости, она то подсвечивается, то нет (чаще - нет, закономерности не понял). Хотелось бы увидеть её подсвеченной, когда прокручиваю код мышью, не трогая курсор.

3. В конце глобальника (свыше 25 тыс. строк) начинаются глюки с прорисовкой линий и отметок в gutter'е: если немного поиграться со свёрткой-развёрткой, отметки о начале/конце конструкций в gutter'е "разъезжаются" и начинают показывать не там и не то. Вообще, двойной щелчок в gutter'е в этой ситуации приводит даже к лёгкому помешательству в коде Улыбка, который вроде пропадает, если покрутить код мышкой туда-сюда.
  
Наверх
www  
IP записан
 
metaeditor
1c++ power user
Отсутствует


are you nuts?

Сообщений: 564
Зарегистрирован: 04. Июля 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #20 - 21. Февраля 2007 :: 11:54
Печать  
Цитата:
ssn1978
Пожелание: Автоматическое разворачивание всех процедур перед сохранением конфигурации.

Хотел сделать, но откался от этой идеи. Придерживаюсь мысли, что всё должно быть контролируемо самим пользователем, никаких автоматических своротов или разворотов, только предупреждения в критических местах.
Цитата:
почему у меня дома ругается, если сохраняешь конфу при свернутых процедурах,
а на работе поставил и сохраняет без вопросов при свернутых процедурах, от чего зависит?

Момент сохранение конфигурации не отлавливается, предупреждение появляется только при попытке закрытия окна со свернутыми методами, может какойнибудь скрипт обрабатывает событие конфигуратора Configurator_MetaDataSaved и пробует чтото закрыть?

Цитата:
The gray CardinalЕсли не устанавливать скрипт, проблемы с прорисовкой (WinXP SP2, 7.70.025). Так и должно быть?

да, по умолчанию все цвета 0 (чёрный)

Цитата:
bsa
Выделение по SelectInnerBlock - думаю имело бы смысл выделять не то, что находится между Если-КонецЕсли и Цикл-КонецЦикла (т.е. включая и условия), а только строки в рамках этих конструкций (исключая условия).

принято
Цитата:
Сейчас подстветка конструкций Если/Цикл и т.д. происходит всегда при позиционировании курсора на любом из ключевых слов конструкции. Если "пройти" курсором вверх или вниз по тексту, где есть эти конструкции, все они автоматом подствечиваются и текст начинает "рябить". 
а) Хотелось бы иметь возможность "сбросить" все подстветки. Может быть реализовать для этого отдельный метод.

Не совсем понял. Режим OColorer.HighlightModeAlways какой? Рябить, всмысле при выходе курсора из ключевого слова его нормальный вид не восстанавливается, подсветка не снимается? можно картинку? (только сложи в архив, чтобы она автоматом не показывалась и не "утяжеляла" ветку)

Цитата:
сделать автоматическую подстветку этих конструкций опциональной
то есть, отдельный метод, типа "ПодсветитьПарнуюСкобку"? можно

Цитата:
trdm
"Пропадают" инстансы. Вжик и нету предприятия или конфигуратора.. ((

это как? где пропадают? вылетает конфигуратор?
Цитата:
при подсветке скобок непонятно где курсор стоит. 
Приходится ждать мигания курсора что-бы понять где он.
Да в принципе в любой подсвеченной инструкции. 

ну а что поделать ) , можно подобрать какойнибудь другой вариант подсветки, плюс попробую сделать подсветку текущей строки, как было сказано выше по ветке.

Цитата:
The gray Cardinal
Замеченные неприятности...


Про все эти неприятности знаю и ждал вопросов. Все исходят из того что анализируется только видимый в данный момент на экране текст. Считается что если на виду нет "процедура/функция" то мы внутри здорового метода, и слева рисуется черта на всю высоту, а в глобальниках как правило в начале на пару страниц идёт куча обьявлений переменных и "далее" методов. Также и со скобками, если одна ушла за пределы видимости то и вторая неподсвечивается. Я думаю над этим.

Цитата:
В конце глобальника (свыше 25 тыс. строк) начинаются глюки с прорисовкой линий и отметок в gutter'е: если немного поиграться со свёрткой-развёрткой

Это нетолько в глобальном а и в конце любых модулей, если свернуть самый последний метод, то под ним образуется пустота. После прокрутки мышью всё восстанавливается.
  

Регистр.EAX.СводныйОстаток()
Наверх
 
IP записан
 
bsa
Junior Member
**
Отсутствует


Не профессионал но и не
любитель...

Сообщений: 27
Местоположение: Одесса
Зарегистрирован: 20. Июня 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #21 - 21. Февраля 2007 :: 12:15
Печать  
Цитата:
Не совсем понял. Режим OColorer.HighlightModeAlways какой?

Код
Выбрать все
OColorer.HighlightModeAlways = false 


Цитата:
Рябить, всмысле при выходе курсора из ключевого слова его нормальный вид не восстанавливается, подсветка не снимается? можно картинку?

Именно так. Наверное это связано с тем, что у меня стоит нестандартный фон окна, т.к. на белом фоне ничего подобного не наблюдается.
  

Rezult.zip ( 71 KB | Загрузки )
Наверх
ICQ  
IP записан
 
metaeditor
1c++ power user
Отсутствует


are you nuts?

Сообщений: 564
Зарегистрирован: 04. Июля 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #22 - 21. Февраля 2007 :: 12:33
Печать  
bsa писал(а) 21. Февраля 2007 :: 12:15:
Наверное это связано с тем, что у меня стоит нестандартный фон окна, т.к. на белом фоне ничего подобного не наблюдается.


Да нет, при любом цвете фона работает. Кстати где ты взял такой цвет, в настройках конфигуратора такого вроде нет, прямо в реестре исправлял или это jpg так исказило?
  

Регистр.EAX.СводныйОстаток()
Наверх
 
IP записан
 
trdm
1c++ power user
qt1l developer
1c++ moderator
Отсутствует



Сообщений: 2343
Местоположение: г. Ростов-на-Дону
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #23 - 21. Февраля 2007 :: 12:35
Печать  
metaeditor писал(а) 21. Февраля 2007 :: 11:54:
Цитата:
trdm
"Пропадают" инстансы. Вжик и нету предприятия или конфигуратора.. ((

это как? где пропадают? вылетает конфигуратор?
Цитата:
при подсветке скобок непонятно где курсор стоит.  
Приходится ждать мигания курсора что-бы понять где он.
Да в принципе в любой подсвеченной инструкции.  

ну а что поделать ) , можно подобрать какойнибудь другой вариант подсветки, плюс попробую сделать подсветку текущей строки, как было сказано выше по ветке.

1. да вот пропадают так что остается вопрос "блин, я ж открывал на этой БД конфигуратор" и где он (с большими глазами). Может из-за того, что 3-4 инстансы было задействовано...
2. Визуал ассист для VC 6.0 видел? Он там скобки просто жирным подрисовывает. Может просто подчеркивание сделать? Хватит за глаза...
  
Наверх
IP записан
 
bsa
Junior Member
**
Отсутствует


Не профессионал но и не
любитель...

Сообщений: 27
Местоположение: Одесса
Зарегистрирован: 20. Июня 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #24 - 21. Февраля 2007 :: 12:39
Печать  
Цитата:
Да нет, при любом цвете фона работает.

Странно...  Печаль
Цитата:
Кстати где ты взял такой цвет, в настройках конфигуратора такого вроде нет, прямо в реестре исправлял или это jpg так исказило?

Цветовая схема "Классическая" Windows XP. В предопределенных вариантах цвета - это слева крайний нижний.
  
Наверх
ICQ  
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #25 - 21. Февраля 2007 :: 12:40
Печать  
Цитата:
2. Визуал ассист для VC 6.0 видел?

Небольшой ОФФ - очень кульная вещь, рекомендую, реально помогает в разработке Улыбка
ЗЫ и лекарства есть Улыбка

  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
trdm
1c++ power user
qt1l developer
1c++ moderator
Отсутствует



Сообщений: 2343
Местоположение: г. Ростов-на-Дону
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #26 - 21. Февраля 2007 :: 12:55
Печать  
artbear писал(а) 21. Февраля 2007 :: 12:40:
Цитата:
2. Визуал ассист для VC 6.0 видел?

Небольшой ОФФ - очень кульная вещь, рекомендую, реально помогает в разработке Улыбка
ЗЫ и лекарства есть Улыбка

сори, за офф-топ, Артур ты с Арахисом как разобрался?
  

unnamed.GIF ( 22 KB | Загрузки )
unnamed.GIF
Наверх
IP записан
 
metaeditor
1c++ power user
Отсутствует


are you nuts?

Сообщений: 564
Зарегистрирован: 04. Июля 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #27 - 21. Февраля 2007 :: 13:09
Печать  
Цитата:
1. да вот пропадают так что остается вопрос "блин, я ж открывал на этой БД конфигуратор" и где он (с большими глазами). Может из-за того, что 3-4 инстансы было задействовано...

попробую тоже позапускать несколько...

Цитата:
2. Визуал ассист для VC 6.0 видел? Он там скобки просто жирным подрисовывает. Может просто подчеркивание сделать? Хватит за глаза...
ассист стоИт, хочу круглые скобки тоже просто жирным шрифтом подсвечивать...
а тип подсветки, ты же сам можеш настроить, в скрипте, хоть подчеркивание  хоть что...
  

Регистр.EAX.СводныйОстаток()
Наверх
 
IP записан
 
metaeditor
1c++ power user
Отсутствует


are you nuts?

Сообщений: 564
Зарегистрирован: 04. Июля 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #28 - 21. Февраля 2007 :: 13:18
Печать  
Цитата:
bsa
В предопределенных вариантах цвета - это слева крайний нижний.

эффект повторился, разбирусь. зы, у меня он темно красный, ближе к коричневому.

хотя, нет, поспешил, перезагрузил конфигуратор, заработало нормально... всёравно посмотрю ещё...
  

Регистр.EAX.СводныйОстаток()
Наверх
 
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #29 - 21. Февраля 2007 :: 13:20
Печать  
trdm писал(а) 21. Февраля 2007 :: 12:55:
сори, за офф-топ, Артур ты с Арахисом как разобрался?

никак Печаль
так кдифф и юзаю Улыбка
Был бы рад, если бы кто помог  Смех
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
Переключение на Главную Страницу Страницы: 1 [2] 3 4 ... 66
ОтправитьПечать