Переключение на Главную Страницу Страницы: [1] 2  ОтправитьПечать
Горячая тема (более 10 ответов) Переход на 1С++ 2.5 (новый TurboMD тоже тут) (число прочтений - 28973 )
fez
Forum Administrator
1c++ power user
Отсутствует


I wanted to cry, but the
tears wouldn't come

Сообщений: 2712
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Переход на 1С++ 2.5 (новый TurboMD тоже тут)
23. Октября 2007 :: 18:28
Печать  
Тут складываем проблемы, возникшие при переходе на 1С++ 2.5.
Без флейма плиз. Только описание проблемы и способ решения (если известен).
« Последняя редакция: 28. Августа 2008 :: 08:14 - fez »  
Наверх
www  
IP записан
 
fez
Forum Administrator
1c++ power user
Отсутствует


I wanted to cry, but the
tears wouldn't come

Сообщений: 2712
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Переход на 1С++ 2.5
Ответ #1 - 23. Октября 2007 :: 18:30
Печать  
1. Имя встроенного в 1С++ класса "СервисРасшФорм". В FormEx этот класс называется "Сервис".

Решается или перелопачиванием конфигурации, или прописыванием наследника от класса "Сервис" с именем "СервисРасшФорм".
  
Наверх
www  
IP записан
 
fez
Forum Administrator
1c++ power user
Отсутствует


I wanted to cry, but the
tears wouldn't come

Сообщений: 2712
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Переход на 1С++ 2.5
Ответ #2 - 23. Октября 2007 :: 18:32
Печать  
2. Несовместимость 1С++ 2.5 с TurboMD версии 1.0.1.11 и ранее.

Решение: http://www.1cpp.ru/forum/YaBB.pl?num=1160630298
Это пока не релиз и части функционала там нет, но надеемся на скорое решение проблемы.
  
Наверх
www  
IP записан
 
slider26
Senior Member
****
Отсутствует


I Love YaBB 2!

Сообщений: 256
Зарегистрирован: 01. Июня 2006
Re: Переход на 1С++ 2.5
Ответ #3 - 24. Октября 2007 :: 03:08
Печать  
Мне пришлось переписать создание ТП:
Код
Выбрать все
Если (глИспользуемОтдельнуюФормЭкс = 0) Тогда
  РасшФормы = СоздатьОбъект("РасширениеФормы");
  ТабПоле = РасшФормы.ПолучитьАтрибут("КнопкаТП").СоздатьЭлементУправления(ЭкземплярТП);
Иначе
  _Форма = СоздатьОбъект("Форма");
  ТабПоле = _Форма.СоздатьЭлементУправленияНаФорме(Форма, ЭкземплярТП, "КнопкаТП");
КонецЕсли;
 


И ещё, перестали перерисовываться реквизиты (или вернее, отрабатывать формулы, повешеные на реквизиты) при активизации строки ТП:
Код
Выбрать все
Процедура ТабПолеПриАктивизацииСтроки()  

  //----Здесь изменяются служебные переменные, которые выводятся реквизитами формы - доп. информация по тек. строке----

  Если (глИспользуемОтдельнуюФормЭкс = 1) Тогда
    Форма.Обновить();
  КонецЕсли;

КонецПроцедуры	// ТабПолеПриАктивизацииСтроки
 


  
Наверх
 
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Переход на 1С++ 2.5
Ответ #4 - 24. Марта 2008 :: 10:08
Печать  
Лично я знаю, что возможны грабли с использованием значений по умолчанию, т.к. в 203 не исправлены подобные ошибки, и пользователи могли их использовать 
Была тема, в которой мы это обсуждали.
Ошибки могут быть для различных классов, как пользовательских, так и встроенных в 1С++.
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
pvase
God Member
*****
Отсутствует



Сообщений: 923
Местоположение: Киев
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Переход на 1С++ 2.5
Ответ #5 - 27. Мая 2008 :: 06:33
Печать  
Не срабатывает возвращение указателя мышки при использовании "Общие.Форма.Привязка.ert". Т.е. указатель переходит в состояние изменения размера, а обратно не возвращается. Пример выкладываю, как решить - пока неизвестно.
(версия 1С++ - 2.5.0.6, такая же беда и в 3.0.0.0).
  

Privjazka_001.zip ( 14 KB | Загрузки )
Наверх
IP записан
 
Chieftain
Senior Member
****
Отсутствует


___

Сообщений: 498
Местоположение: Тула
Зарегистрирован: 15. Февраля 2007
Пол: Мужской
Re: Переход на 1С++ 2.5
Ответ #6 - 27. Мая 2008 :: 12:15
Печать  
pvase писал(а) 27. Мая 2008 :: 06:33:
Не срабатывает возвращение указателя мышки при использовании "Общие.Форма.Привязка.ert". Т.е. указатель переходит в состояние изменения размера, а обратно не возвращается. Пример выкладываю, как решить - пока неизвестно.
(версия 1С++ - 2.5.0.6, такая же беда и в 3.0.0.0).

Было уже http://www.1cpp.ru/forum/YaBB.pl?num=1178868866
  
Наверх
ICQ  
IP записан
 
Kostas
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 9
Зарегистрирован: 19. Октября 2010
Re: Переход на 1С++ 2.5 (новый TurboMD тоже тут)
Ответ #7 - 15. Ноября 2010 :: 18:48
Печать  
Имеею:
- Windows 7
- 1c 7.7.027
- 1c++2.5.07
- FormEx 2.0.5.101
Когда загружены обе компоненты все работает нармуль, но при выходе из 1С, Винда ругается
Компоненты грузятся в глобальнике.

Код
Выбрать все
Процедура ПриНачалеРаботыСистемы()
  Попытка
    ЗагрузитьВнешнююКомпоненту("1cpp.dll");
    ЗагрузитьВнешнююКомпоненту("FormEx.dll");
  Исключение
    Сообщить("Ошибки при загрузке компоненты 1С++.", "!!!");
  КонецПопытки;
КонецПроцедуры; 



Если не грузить 1с++ то ошибки нет
  

_______.png ( 44 KB | Загрузки )
_______.png
Наверх
 
IP записан
 
Z1
God Member
*****
Отсутствует


I Love YaBB 2!

Сообщений: 2906
Местоположение: Москва
Зарегистрирован: 26. Мая 2006
Пол: Мужской
Re: Переход на 1С++ 2.5 (новый TurboMD тоже тут)
Ответ #8 - 16. Ноября 2010 :: 05:45
Печать  
попробуй 1cpp 3.2.3.2
  
Наверх
 
IP записан
 
Anatol
Senior Member
****
Отсутствует


тыц, пыц, тыц!!!

Сообщений: 412
Зарегистрирован: 24. Апреля 2009
Re: Переход на 1С++ 2.5 (новый TurboMD тоже тут)
Ответ #9 - 16. Ноября 2010 :: 06:09
Печать  
или если решил остаться на старой версии, то нужно использовать лоадер
  
Наверх
wwwICQ  
IP записан
 
Kostas
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 9
Зарегистрирован: 19. Октября 2010
Re: Переход на 1С++ 2.5 (новый TurboMD тоже тут)
Ответ #10 - 16. Ноября 2010 :: 07:51
Печать  
Цитата:
попробуй 1cpp 3.2.3.2
- Пасибо. Все работает нормально.  Улыбка

Цитата:
или если решил остаться на старой версии, то нужно использовать лоадер
- Не знаю где брать да и не понадобился  Подмигивание Пасиба
Вот тока закладка в 1с\сервис\параметры - куда то делась. Озадачен
  
Наверх
 
IP записан
 
ЮраОС
Junior Member
**
Отсутствует


1C++ rocks!

Сообщений: 68
Местоположение: Новосибирск
Зарегистрирован: 12. Сентября 2011
Пол: Мужской
Re: Переход на 1С++ 2.5 (новый TurboMD тоже тут)
Ответ #11 - 23. Ноября 2011 :: 12:53
Печать  
Доброго времени суток, народ!
Пытался перейти с 1сpp2037 на 1сpp2507...
... возникли проблеммы с турбоМД.
При подмене модуля документа при проведении не признает подмены. А при подменене модуля формы отчета - юзвера убивает при попытке открыть форму отчета (то бишь 1с падает).  Ужас Пришлось вернуть все обратно.
Ни кто не подскажет как это можно забороть???
  
Наверх
IP записан
 
ЮраОС
Junior Member
**
Отсутствует


1C++ rocks!

Сообщений: 68
Местоположение: Новосибирск
Зарегистрирован: 12. Сентября 2011
Пол: Мужской
Re: Переход на 1С++ 2.5 (новый TurboMD тоже тут)
Ответ #12 - 23. Ноября 2011 :: 12:56
Печать  
ЮраОС писал(а) 23. Ноября 2011 :: 12:53:
Доброго времени суток, народ!
Пытался перейти с 1сpp2037 на 1сpp2507...
... возникли проблеммы с турбоМД.
При подмене модуля документа при проведении не признает подмены. А при подменене модуля формы отчета - юзвера убивает при попытке открыть форму отчета (то бишь 1с падает).  Ужас Пришлось вернуть все обратно.
Ни кто не подскажет как это можно забороть???

turbomd.dll вроде последней версии судя по номеру ...
... свежее не нашел.  Злой
  
Наверх
IP записан
 
varelchik
God Member
*****
Отсутствует


I Love YaBB 2!

Сообщений: 788
Зарегистрирован: 22. Мая 2006
Re: Переход на 1С++ 2.5 (новый TurboMD тоже тут)
Ответ #13 - 23. Ноября 2011 :: 13:04
Печать  
Уходил бы ты с 2.х на 3.х
а версия у turbomd должна быть 1.0.0.1
  
Наверх
 
IP записан
 
ЮраОС
Junior Member
**
Отсутствует


1C++ rocks!

Сообщений: 68
Местоположение: Новосибирск
Зарегистрирован: 12. Сентября 2011
Пол: Мужской
Re: Переход на 1С++ 2.5 (новый TurboMD тоже тут)
Ответ #14 - 23. Ноября 2011 :: 13:37
Печать  
varelchik писал(а) 23. Ноября 2011 :: 13:04:
Уходил бы ты с 2.х на 3.х
а версия у turbomd должна быть 1.0.0.1

дык все смотрю на волшебные слова ...
рекомендуемый стабильный релиз ... Улыбка
из 3.х какой релиз "рекомедуемый, не знаю насколько стабилный" ?
последняя версия 1cpp вроде все еще 3.2.2.0 ???
  
Наверх
IP записан
 
Переключение на Главную Страницу Страницы: [1] 2 
ОтправитьПечать