Переключение на Главную Страницу Страницы: 1 ОтправитьПечать
Обычная тема Звуки клавиш (число прочтений - 2784 )
OleLykoye
YaBB Newbies
*
Отсутствует


No pasaran

Сообщений: 4
Зарегистрирован: 29. Октября 2007
Звуки клавиш
29. Октября 2007 :: 06:28
Печать  
Здравствуйте. у меня такая проблема:
Написал код  с процедурой
ПриНажатииКнопкиКлавиатуры(КодКлавишы,Альт,Шифт,Контрол,Символ,Флаг)

Все работает прекрасно с одним НО, при нажатии на клавишу издается звук., причем спец клавиши не "звучат" (например верх, вниз, альт, шифт и тд.) а цифры-буквы звучат. Звук такой как если бы вы попытались уйти с модального окна на родительское.

Как убрать звук? А то все время кажется что у меня где то ошибка.
Причем звучат как в модальных окнах так и не в модальных

Заранее спасибо.

Процедура ПриНажатииКнопкиКлавиатуры(КодКлавишы,Альт,Шифт,Контрол,Символ,Флаг)
     Если КодКлавишы=38 Тогда                  
           //Сдвиг(+)
     КонецЕсли;
     
     //***************** 40 ********Вниз************************************
     Если КодКлавишы=40 Тогда                  
           //Сдвиг(-)
     КонецЕсли;
     
           
     //***************** 48-57 *********ввели число*******************
     Если (КодКлавишы>=48) и (КодКлавишы<=57) Тогда   
           //Введенный=Симв(КодКлавишы);
           //РезультатЦифер("+",Введенный);
     КонецЕсли;
     
     //***************** 8 *********забой*******************
     Если КодКлавишы=8 тогда            
           //РезультатЦифер("-");
     КонецЕсли;      
     
КонецПроцедуры

     
« Последняя редакция: 29. Октября 2007 :: 18:34 - OleLykoye »  
Наверх
 
IP записан
 
Valet
Full Member
***
Отсутствует



Сообщений: 141
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Звуки клавиш
Ответ #1 - 29. Октября 2007 :: 08:50
Печать  
Мне кажется ты получишь ответ быстрее  Улыбка ,
если выложишь код процедуры ПриНажатииКнопкиКлавиатуры().
  

/ Лень - двигатель прогресса. /
Наверх
ICQ  
IP записан
 
OleLykoye
YaBB Newbies
*
Отсутствует


No pasaran

Сообщений: 4
Зарегистрирован: 29. Октября 2007
Re: Звуки клавиш
Ответ #2 - 31. Октября 2007 :: 13:59
Печать  
Наверно все таки эта проблема никого не интересует ((..
Мне кажется что звук возникает из-за того что вслед за кодом клавишы, идет какой нить спец символ на который система реагирует звуком
Может я не прав..кто нибудь может поставить точку?
  
Наверх
 
IP записан
 
АЛьФ
FormEx developer
1c++ developer
Отсутствует



Сообщений: 1532
Местоположение: Санкт-Петербург
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Звуки клавиш
Ответ #3 - 31. Октября 2007 :: 16:31
Печать  
А не надо отвечать путем редактирования своего предыдущего сообщения. Ни кто ж не видит, что ветка обновилась.
Где эта процедура расположена?
Сможешь сделать тестовую конфигу, на которой это можно будет воспроизвести?
  

FormEx developer
Наверх
www  
IP записан
 
Ariets
YaBB Newbies
*
Отсутствует


I Love YaBB 2!

Сообщений: 2
Зарегистрирован: 31. Октября 2007
Re: Звуки клавиш
Ответ #4 - 31. Октября 2007 :: 17:37
Печать  
в нужном месте сделай Флаг=0;
сдается мне, что у тебя ТЧ и 1С пытается осуществить поиск в колонке по набранным символам (не находит и выдает звуковой сигнал)
  
Наверх
 
IP записан
 
OleLykoye
YaBB Newbies
*
Отсутствует


No pasaran

Сообщений: 4
Зарегистрирован: 29. Октября 2007
Re: Звуки клавиш
Ответ #5 - 02. Ноября 2007 :: 02:45
Печать  
За обновление извини ..а за Флаг спасибо помогло..
  
Наверх
 
IP записан
 
Переключение на Главную Страницу Страницы: 1
ОтправитьПечать