Переключение на Главную Страницу Страницы: 1 2 [3] 4  ОтправитьПечать
Очень популярная тема (более 25 ответов) Маленький класс для создания закладок (число прочтений - 21674 )
admin spb
Full Member
***
Отсутствует


I Love YaBB 2!

Сообщений: 150
Зарегистрирован: 26. Апреля 2007
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #30 - 20. Февраля 2008 :: 12:21
Печать  
МОЯ БАЗА ПО ЗАКАЗАМ - ПОЛ-ГОДА ВСЕГО ЗНАЮ 1С  Улыбка
  

333.rar ( 26 KB | Загрузки )
Наверх
 
IP записан
 
Kapet
Senior Member
****
Отсутствует


Ламер - вансист

Сообщений: 262
Местоположение: Ukraine, Kyiv
Зарегистрирован: 27. Декабря 2006
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #31 - 20. Февраля 2008 :: 15:27
Печать  
admin spb писал(а) 20. Февраля 2008 :: 12:21:
МОЯ БАЗА ПО ЗАКАЗАМ - ПОЛ-ГОДА ВСЕГО ЗНАЮ 1С  Улыбка

Кто похвалит меня лучше всех, тот получит вкусную конфету...

ЗЫ. Я бы перевел этот отчет в табличное поле...
  
Наверх
ICQ  
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #32 - 21. Февраля 2008 :: 04:43
Печать  
Kapet писал(а) 20. Февраля 2008 :: 15:27:
admin spb писал(а) 20. Февраля 2008 :: 12:21:
МОЯ БАЗА ПО ЗАКАЗАМ - ПОЛ-ГОДА ВСЕГО ЗНАЮ 1С  Улыбка

Кто похвалит меня лучше всех, тот получит вкусную конфету...

ЗЫ. Я бы перевел этот отчет в табличное поле...


Ты не поверишь но если верить автору то оно и так на ТП сделано  Подмигивание
Приблизительно суть (со слов автора, сам не видел): сначала на все ТП выставляем большой шрифт, потом при выводе делает шрифт меньше  Очень довольный
ПОВТОРЮСЬ: Сам я не пробовал  Круглые глаза
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
Nick
God Member
*****
Отсутствует



Сообщений: 1599
Местоположение: г.Новокузнецк
Зарегистрирован: 21. Февраля 2007
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #33 - 21. Февраля 2008 :: 04:54
Печать  
admin spb писал(а) 20. Февраля 2008 :: 12:21:
МОЯ БАЗА ПО ЗАКАЗАМ - ПОЛ-ГОДА ВСЕГО ЗНАЮ 1С  Улыбка


Вполне юзабельно, только что то я не припомню чтоб у ТП был многострочный текст  Ужас
  
Наверх
ICQ  
IP записан
 
admin spb
Full Member
***
Отсутствует


I Love YaBB 2!

Сообщений: 150
Зарегистрирован: 26. Апреля 2007
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #34 - 21. Февраля 2008 :: 10:59
Печать  
РазделительСрок Улыбка
  
Наверх
 
IP записан
 
vip
1c++ power user
Отсутствует



Сообщений: 1570
Зарегистрирован: 19. Мая 2006
Re: Маленький класс для создания закладок
Ответ #35 - 21. Февраля 2008 :: 11:41
Печать  
admin spb писал(а) 21. Февраля 2008 :: 10:59:
РазделительСрок Улыбка

Гм... Действительно работает. Улыбка
  
Наверх
ICQ  
IP записан
 
Kapet
Senior Member
****
Отсутствует


Ламер - вансист

Сообщений: 262
Местоположение: Ukraine, Kyiv
Зарегистрирован: 27. Декабря 2006
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #36 - 21. Февраля 2008 :: 17:29
Печать  
Переделка и оптимизация класса:

1. Убрана ненужная ТаблицаЗакладок, соответственно модуль похудел более чем в два раза, увеличилась скорость работы.

2. Несколько изменен метод работы:
Создание:
Код
Выбрать все
Процедура ПослеОткрытия()
	Закладки=СоздатьОбъект("Общие.Форма.Закладки");
	Закладки.Создать(Контекст,"ФормаЗакладки");
	Закладки.Параметры(глПолучитьЦвет(193,205,205),"",0,0,0);
	//
	Закладки.Добавить("Основной","Общие","Общие данные сотрудника");
	Закладки.Добавить("Зарплата","Зарплата","Данные по з/п");
	Закладки.Добавить("Паспорт","Документы","Документы сотрудника");
	Закладки.Добавить("Налоговые","Налоговые данные","Налоговые данные сотрудника");
КонецПроцедуры 


Обработка события переключения:
Код
Выбрать все
Процедура ФормаЗакладки_Change()
	Форма.ИспользоватьСлой("Общий,"+Закладки.ТекущаяЗакладка(),2);
КонецПроцедуры 


В классе для процедур и функций есть краткие комментарии.

3. В заключение не забываем, что этот контрол управляется Басиком, у которого истина = -1, и ложь = 0, и нумерация закладок идет от 0 до КоличествоЗакладок-1.

Всем успехов, а автору БОЛЬШОЙ СПАСИБ!
  

TabbedForm_007.rar ( 8 KB | Загрузки )
Наверх
ICQ  
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #37 - 22. Февраля 2008 :: 04:23
Печать  
Kapet писал(а) 21. Февраля 2008 :: 17:29:
Переделка и Всем успехов, а автору БОЛЬШОЙ СПАСИБ!


Всегда пожалуйста  Подмигивание

Только вот вопрос...
Посмотрел всю переделку, согласен что так выгоднее с точки зрения физического размера класса, но в принципе ИМХО не сильно скажется на производительности. Или я не прав?  Очень довольный
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
Kapet
Senior Member
****
Отсутствует


Ламер - вансист

Сообщений: 262
Местоположение: Ukraine, Kyiv
Зарегистрирован: 27. Декабря 2006
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #38 - 22. Февраля 2008 :: 08:10
Печать  
vandalsvq писал(а) 22. Февраля 2008 :: 04:23:
Kapet писал(а) 21. Февраля 2008 :: 17:29:
Переделка и Всем успехов, а автору БОЛЬШОЙ СПАСИБ!


Всегда пожалуйста  Подмигивание

Только вот вопрос...
Посмотрел всю переделку, согласен что так выгоднее с точки зрения физического размера класса, но в принципе ИМХО не сильно скажется на производительности. Или я не прав?  Очень довольный

Конечно, повышение скорости обработки чепуховая, полностью согласен. Просто как-то сразу было видно, что ТаблицаЗакладок в этом классе - вещь перемудрённая, и подлежит искоренению. Также согласен, что править легче, чем творить, поэтому по-прежнему благодарю за удачную идею и практическую реализацию стартового релиза. Также,  вместе со всеми, жду от Вас новых хороших идей и их практической реализации. В общем, Уфа рулит...  Улыбка
  
Наверх
ICQ  
IP записан
 
admin spb
Full Member
***
Отсутствует


I Love YaBB 2!

Сообщений: 150
Зарегистрирован: 26. Апреля 2007
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #39 - 28. Февраля 2008 :: 07:47
Печать  
Еще добавим в класс возможность получения кол-во закладок:

Функция ПолучитьКолВоЗакладок()  Экспорт
  Возврат ТаблицаЗакладок.КоличествоСтрок();
КонецФункции 


Прошу автора добавить... Заранее Спасибо!
  
Наверх
 
IP записан
 
admin spb
Full Member
***
Отсутствует


I Love YaBB 2!

Сообщений: 150
Зарегистрирован: 26. Апреля 2007
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #40 - 28. Февраля 2008 :: 07:53
Печать  
Было бы не плохо, если бы можно:
1. Для каждой закладки задавать свой шрифт и цвет шрифта.
2. Добавить картинку на каждую закладку.
3. Как то подсвечивать закладку...
  
Наверх
 
IP записан
 
Kapet
Senior Member
****
Отсутствует


Ламер - вансист

Сообщений: 262
Местоположение: Ukraine, Kyiv
Зарегистрирован: 27. Декабря 2006
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #41 - 28. Февраля 2008 :: 14:39
Печать  
admin spb писал(а) 28. Февраля 2008 :: 07:47:
Еще добавим в класс возможность получения кол-во закладок:

Функция ПолучитьКолВоЗакладок()  Экспорт
 Возврат ТаблицаЗакладок.КоличествоСтрок();
КонецФункции  


Прошу автора добавить... Заранее Спасибо!

Аналогично, для этого класса без ТаблицаЗакладок:
Код
Выбрать все
Функция Количество() Экспорт
	Возврат Страницы.Count();
КонецФункции 


и, на всякий случай добавляем удаление всех закладок
Код
Выбрать все
Процедура Очистить() Экспорт
	Страницы.Clear();
КонецПроцедуры 

  
Наверх
ICQ  
IP записан
 
Kapet
Senior Member
****
Отсутствует


Ламер - вансист

Сообщений: 262
Местоположение: Ukraine, Kyiv
Зарегистрирован: 27. Декабря 2006
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #42 - 28. Февраля 2008 :: 14:46
Печать  
admin spb писал(а) 28. Февраля 2008 :: 07:53:
Было бы не плохо, если бы можно:
1. Для каждой закладки задавать свой шрифт и цвет шрифта.
2. Добавить картинку на каждую закладку.
3. Как то подсвечивать закладку...

Картинки добавить можно, у автора же в классе есть забаненый пример.
Остальное с этим эктивэксом невозможно по причине его ограничений по свойствам и методам. Посмотреть всё можешь без проблем сам, если у тя стоит какой нибудь из последних мелкомягких офисов.
  
Наверх
ICQ  
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #43 - 28. Февраля 2008 :: 17:43
Печать  
admin spb писал(а) 28. Февраля 2008 :: 07:53:
Было бы не плохо, если бы можно:
1. Для каждой закладки задавать свой шрифт и цвет шрифта.
2. Добавить картинку на каждую закладку.
3. Как то подсвечивать закладку...


Скорее всего на этом поддержка этого класса окончена.
Будут картинки, будет КоличествоЗакладок, будет УдалитьВсеЗакладки... когда не скажу, т.к. счас даже времени открыть его нет.
Остальное все как правильно сказал kapet выходит за рамки возможности данного ActiveX.
Расширение будет только с появлением нового КОП на базе ActiveX от компании Codejock. На нем будут многие вещи которые уже счас хотелось бы и то что даже не думается в качестве хотелок сейчас. Но его появление пока туманная перспектива.  Нерешительный Так что как говорится "при первой возможности" обязательно все сделаю  Класс
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
admin spb
Full Member
***
Отсутствует


I Love YaBB 2!

Сообщений: 150
Зарегистрирован: 26. Апреля 2007
Пол: Мужской
Re: Маленький класс для создания закладок
Ответ #44 - 20. Марта 2008 :: 11:28
Печать  
ждем... ждем Печаль
  
Наверх
 
IP записан
 
Переключение на Главную Страницу Страницы: 1 2 [3] 4 
ОтправитьПечать