Переключение на Главную Страницу Страницы: 1 ... 13 14 [15]  ОтправитьПечать
Очень популярная тема (более 25 ответов) Colorer for Openconf - обсуждения (2) (число прочтений - 131112 )
alyuev
God Member
*****
Отсутствует


Гражданин Вселенной

Сообщений: 851
Местоположение: Одесса
Зарегистрирован: 07. Декабря 2007
Пол: Мужской
Re: Colorer for Openconf - обсуждения (2)
Ответ #210 - 16. Мая 2014 :: 10:14
Печать  
Спасибо. Получилось типа такого:

Код
Выбрать все
Процедура ScintillaControlOnCharAdded(control,ch)
	Перем curPos,НомПредСтр,ПредСтр,ПервСимволПред,ПозПервСимвола,ПредОтступ,ПервоеСлово;
	Если ch=10 Тогда //делаем Авто-Отступ (Auto-Indent)
		curPos = control.GetCurrentPos();
		НомПредСтр=control.LineFromPosition(curPos-1);
		ПредСтр=СтрПолучитьСтроку(control.GetLine(НомПредСтр),1);
		Если СокрЛП(ПредСтр)="" Тогда
			ПредОтступ  = ПредСтр;
		Иначе
			//Вычленяем отступ предыдущей строки
			ПервСимволПред = Лев(СокрЛП(ПредСтр),1);
			ПозПервСимвола = Найти(ПредСтр,ПервСимволПред);
			ПредОтступ  = Лев(ПредСтр,ПозПервСимвола-1);
			ПервоеСлово = СловоПоНомеру(СокрЛП(ПредСтр),1); //Здесь используется наша функция по вырезанию нужного слова. Можно убрать это и проверку ниже.
			Если найти("для|если|процедура|функция||",Нрег(ПервоеСлово))<>0 Тогда
				ПредОтступ=ПредОтступ+СимволТабуляции;
			КонецЕсли;
		КонецЕсли;
		control.ADDTEXT(стрДлина(ПредОтступ),ПредОтступ); //Вставим в начало отступ
	КонецЕсли;
	Если ch = 46 Тогда // Попытка разобратся, как делать подсказки после точки
		//control.CALLTIPSHOW(1,"Привет"); //Показывается всплывающая подсказка
		//sci.SetKeyWords(0, "select as from on where group having order by asc desc insert values into update set delete limit union"); //ключевые слова
		//control.AUTOCSHOW(0,"AS ASC BY DELETE DESC FROM GROUP HAVING INSERT INTO LIMIT ORDER SELECT UNION UPDATE VALUES WHERE"); // это автозавершение
		//Сообщить("Можем показать подсказку");
		//здесь делаем подсказку
	КонецЕсли;
КонецПроцедуры
 

  

1C 7.7.025; 1C++ 3.2.4.3; Formex 2.0.5.94; 1sqlite
Наверх
IP записан
 
trdm
1c++ power user
qt1l developer
1c++ moderator
Отсутствует



Сообщений: 2343
Местоположение: г. Ростов-на-Дону
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Colorer for Openconf - обсуждения (2)
Ответ #211 - 21. Октября 2014 :: 05:47
Печать  
На моей конфе вылеты участились на столько, что вынужден отказаться от использования плагина Печаль((((((((((((((((((((((
А я к нему уже привык капитально Печаль((((
  
Наверх
IP записан
 
metaeditor
1c++ power user
Отсутствует


are you nuts?

Сообщений: 564
Зарегистрирован: 04. Июля 2006
Пол: Мужской
Re: Colorer for Openconf - обсуждения (2)
Ответ #212 - 30. Октября 2014 :: 11:18
Печать  
Версия 1.0.1.7
- исправлен экзотический случай вылета когда в глобальнике очень много экспортных процедур

(в данном случае оказалось более 1000)

http://www.1cpp.ru/forum/YaBB.pl?num=1197864156/33#33
  

Регистр.EAX.СводныйОстаток()
Наверх
 
IP записан
 
alyuev
God Member
*****
Отсутствует


Гражданин Вселенной

Сообщений: 851
Местоположение: Одесса
Зарегистрирован: 07. Декабря 2007
Пол: Мужской
Re: Colorer for Openconf - обсуждения (2)
Ответ #213 - 30. Октября 2014 :: 11:45
Печать  
Именно процедур?
Просто у нас 1176 экспортных функций и процедур в глобальнике. Из них экспортных процедур 320. Может поэтому пока всё нормально с версией 1.0.1.5?

Всего у нас функций и процедур 1365.
  

1C 7.7.025; 1C++ 3.2.4.3; Formex 2.0.5.94; 1sqlite
Наверх
IP записан
 
metaeditor
1c++ power user
Отсутствует


are you nuts?

Сообщений: 564
Зарегистрирован: 04. Июля 2006
Пол: Мужской
Re: Colorer for Openconf - обсуждения (2)
Ответ #214 - 30. Октября 2014 :: 12:04
Печать  
alyuev писал(а) 30. Октября 2014 :: 11:45:
Именно процедур?
Просто у нас 1176 экспортных функций и процедур в глобальнике. Из них экспортных процедур 320. Может поэтому пока всё нормально с версией 1.0.1.5?
Всего у нас функций и процедур 1365.

глобальных экспортных методов и переменных, незнаю почему у вас работает, по идее недолжно)
  

Регистр.EAX.СводныйОстаток()
Наверх
 
IP записан
 
trdm
1c++ power user
qt1l developer
1c++ moderator
Отсутствует



Сообщений: 2343
Местоположение: г. Ростов-на-Дону
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Colorer for Openconf - обсуждения (2)
Ответ #215 - 31. Октября 2014 :: 10:52
Печать  
metaeditor писал(а) 30. Октября 2014 :: 11:18:
Версия 1.0.1.7
- исправлен экзотический случай вылета когда в глобальнике очень много экспортных процедур

(в данном случае оказалось более 1000)

http://www.1cpp.ru/forum/YaBB.pl?num=1197864156/33#33

Спасибо огромное!  Смех Смех Смех
  
Наверх
IP записан
 
alyuev
God Member
*****
Отсутствует


Гражданин Вселенной

Сообщений: 851
Местоположение: Одесса
Зарегистрирован: 07. Декабря 2007
Пол: Мужской
Re: Colorer for Openconf - обсуждения (2)
Ответ #216 - 18. Декабря 2014 :: 14:05
Печать  
Не подсвечиваются в коде реквизиты формы журналов и списков справочников. В коде формы элемента и документа - всё ок. Версия Colorer - 1.0.1.7
  

1C 7.7.025; 1C++ 3.2.4.3; Formex 2.0.5.94; 1sqlite
Наверх
IP записан
 
alyuev
God Member
*****
Отсутствует


Гражданин Вселенной

Сообщений: 851
Местоположение: Одесса
Зарегистрирован: 07. Декабря 2007
Пол: Мужской
Re: Colorer for Openconf - обсуждения (2)
Ответ #217 - 12. Июня 2017 :: 08:51
Печать  
Привет.

Я правильно понимаю, что обновление в SciLexer.dll версии Scintilla до новых можно даже не обсуждать?

Сейчас сцинтилла там v1.74
  

1C 7.7.025; 1C++ 3.2.4.3; Formex 2.0.5.94; 1sqlite
Наверх
IP записан
 
stepman1
Junior Member
**
Отсутствует


I Love YaBB 2!

Сообщений: 86
Зарегистрирован: 02. Июля 2007
Re: Colorer for Openconf - обсуждения (2)
Ответ #218 - 23. Ноября 2017 :: 05:00
Печать  
Привет.

Можно ли подправить плагин в части быстрого поиска с подсветкой (очень удобная штука)?

Не выводятся наименования процедур и функций, если они оформлены через Procedure, Function.
  
Наверх
 
IP записан
 
metaeditor
1c++ power user
Отсутствует


are you nuts?

Сообщений: 564
Зарегистрирован: 04. Июля 2006
Пол: Мужской
Re: Colorer for Openconf - обсуждения (2)
Ответ #219 - 30. Ноября 2017 :: 11:25
Печать  
давненько я сюда не заходил

alyuev писал(а) 18. Декабря 2014 :: 14:05:
Не подсвечиваются в коде реквизиты формы журналов и списков справочников. В коде формы элемента и документа - всё ок. Версия Colorer - 1.0.1.7

сделал

Цитата:
Я правильно понимаю, что обновление в SciLexer.dll версии Scintilla до новых можно даже не обсуждать?
Сейчас сцинтилла там v1.74

да, исходники порядком доработаны, поднять до текущей версии будет сложно

stepman1 писал(а) 23. Ноября 2017 :: 05:00:
Привет.
Можно ли подправить плагин в части быстрого поиска с подсветкой (очень удобная штука)?
Не выводятся наименования процедур и функций, если они оформлены через Procedure, Function.

сделал

не нашел как тут теперь прикреплять файлы к постам, выложил на инфостарте
https://infostart.ru/public/19544/
  

Регистр.EAX.СводныйОстаток()
Наверх
 
IP записан
 
stepman1
Junior Member
**
Отсутствует


I Love YaBB 2!

Сообщений: 86
Зарегистрирован: 02. Июля 2007
Re: Colorer for Openconf - обсуждения (2)
Ответ #220 - 30. Ноября 2017 :: 16:58
Печать  
Громадное спасибо!

Это просто праздник какой-то  Круглые глаза
  
Наверх
 
IP записан
 
alyuev
God Member
*****
Отсутствует


Гражданин Вселенной

Сообщений: 851
Местоположение: Одесса
Зарегистрирован: 07. Декабря 2007
Пол: Мужской
Re: Colorer for Openconf - обсуждения (2)
Ответ #221 - 08. Декабря 2017 :: 13:22
Печать  
Спасибо, что не оставил нас! Улыбка
  

1C 7.7.025; 1C++ 3.2.4.3; Formex 2.0.5.94; 1sqlite
Наверх
IP записан
 
Переключение на Главную Страницу Страницы: 1 ... 13 14 [15] 
ОтправитьПечать