Переключение на Главную Страницу Страницы: [1]  ОтправитьПечать
Горячая тема (более 10 ответов) Заголовок колонки многострочной части (число прочтений - 6749 )
serg_gres
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 10
Зарегистрирован: 08. Декабря 2008
Заголовок колонки многострочной части
01. Июня 2009 :: 17:22
Печать  
В форме списка справочника в ПриОткрытии(), код:

     
Код
Выбрать все
      ФормаРасш = СоздатьОбъект("РасширениеФормы");
	ФормаРасш.УстановитьФорму(Форма);
	Для Х = 0 По ФормаРасш.КоличествоАтрибутов() - 1 Цикл
		  Сообщить(ФормаРасш.ПолучитьАтрибут(Х).Заголовок);  
	  ФормаРасш.ПолучитьАтрибут(Х).Заголовок="Опа";
	КонецЦикла;  


, меняет заголовки  всех элементов, которые находятся на форме, кроме колонок многострочной части.
Я что-то делаю не правильно или заголовки колонок нельзя поменять?

« Последняя редакция: 01. Июня 2009 :: 19:37 - serg_gres »  
Наверх
 
IP записан
 
blindvic
Senior Member
****
Отсутствует



Сообщений: 486
Местоположение: Moldova
Зарегистрирован: 23. Июня 2008
Пол: Мужской
Re: Заголовок колонки многострочной части
Ответ #1 - 01. Июня 2009 :: 18:38
Печать  
Не знаю, как через ФормЕкс. Без него - вот так:
Код
Выбрать все
Форма.ПолучитьАтрибут ( "ИмяАтрибута").Заголовок ( "Заголовок" ) 

  
Наверх
 
IP записан
 
Eprst
God Member
*****
Отсутствует



Сообщений: 3396
Зарегистрирован: 08. Октября 2007
Re: Заголовок колонки многострочной части
Ответ #2 - 02. Июня 2009 :: 06:03
Печать  
А так ?

Код
Выбрать все
        РасшФ = СоздатьОбъект("РасширениеФормы");
	РасшФ.УстановитьФорму(Форма);
	АтрФормы = СоздатьОбъект("АтрибутФормы");
	Для к = 0 По РасшФ.КоличествоАтрибутов() - 1 Цикл
	       АтрФормы.УстановитьАтрибут(Форма,к);
       	       АтрФормы.Заголовок="Вася";
        КонецЦикла;
        Форма.Обновить(0); 



Цитата:
Не знаю, как через ФормЕкс. Без него - вот так:
Код:

Форма.ПолучитьАтрибут ( "ИмяАтрибута").Заголовок ( "Заголовок" )


Так не поимеешь атрибуты без идентификаторов...да и вообще .


  
Наверх
 
IP записан
 
serg_gres
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 10
Зарегистрирован: 08. Декабря 2008
Re: Заголовок колонки многострочной части
Ответ #3 - 02. Июня 2009 :: 06:44
Печать  
  Цитата:
РасшФ = СоздатьОбъект("РасширениеФормы");
     РасшФ.УстановитьФорму(Форма);
     АтрФормы = СоздатьОбъект("АтрибутФормы");
     Для к = 0 По РасшФ.КоличествоАтрибутов() - 1 Цикл
            АтрФормы.УстановитьАтрибут(Форма,к);
                  АтрФормы.Заголовок="Вася";
       КонецЦикла;
       Форма.Обновить(0);

Так тоже не работает
  
Наверх
 
IP записан
 
Eprst
God Member
*****
Отсутствует



Сообщений: 3396
Зарегистрирован: 08. Октября 2007
Re: Заголовок колонки многострочной части
Ответ #4 - 02. Июня 2009 :: 06:57
Печать  
Странно, спецом проверил, у меня работает.
Формекс, 2.0.5.94
  
Наверх
 
IP записан
 
Mikeware
Senior Member
****
Отсутствует


I Love YaBB 2!

Сообщений: 262
Зарегистрирован: 27. Июля 2006
Пол: Мужской
Re: Заголовок колонки многострочной части
Ответ #5 - 02. Июня 2009 :: 07:06
Печать  
2.0.5.93 - Не работает
  
Наверх
ICQ  
IP записан
 
Eprst
God Member
*****
Отсутствует



Сообщений: 3396
Зарегистрирован: 08. Октября 2007
Re: Заголовок колонки многострочной части
Ответ #6 - 02. Июня 2009 :: 07:21
Печать  
      Цитата:
2.0.5.93 - Не работает


Спецом откатился на младшую 93-ю  - все работает!
Улыбка
Все атрибуты имеют в заголовке - "Вася", и атрибуты ТЧ в том числе.
  

_______002.jpg ( 114 KB | Загрузки )
_______002.jpg
Наверх
 
IP записан
 
serg_gres
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 10
Зарегистрирован: 08. Декабря 2008
Re: Заголовок колонки многострочной части
Ответ #7 - 02. Июня 2009 :: 07:26
Печать  
А почему в т.ч. НДС - не Вася?
  
Наверх
 
IP записан
 
Eprst
God Member
*****
Отсутствует



Сообщений: 3396
Зарегистрирован: 08. Октября 2007
Re: Заголовок колонки многострочной части
Ответ #8 - 02. Июня 2009 :: 07:30
Печать  
Я в ПослеОткрытия атрибуты установил, а там есть еще всякие УправлениеДоступностью/видимостью.. где устанавливается заголовок..
Це же демка комплексной..
Улыбка
  
Наверх
 
IP записан
 
serg_gres
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 10
Зарегистрирован: 08. Декабря 2008
Re: Заголовок колонки многострочной части
Ответ #9 - 02. Июня 2009 :: 07:39
Печать  
Блин, а я в ПриОткрытии() сувал  Озадачен
Тока теперь на тестовой конфиге для FormEx все работает, а на моей 1С-ка вылетает с ошибкой
  
Наверх
 
IP записан
 
Mikeware
Senior Member
****
Отсутствует


I Love YaBB 2!

Сообщений: 262
Зарегистрирован: 27. Июля 2006
Пол: Мужской
Re: Заголовок колонки многострочной части
Ответ #10 - 02. Июня 2009 :: 07:44
Печать  
на dorex.ru лежит только [версия: 2.0.5.93 от 27.10.2008]
  
Наверх
ICQ  
IP записан
 
serg_gres
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 10
Зарегистрирован: 08. Декабря 2008
Re: Заголовок колонки многострочной части
Ответ #11 - 02. Июня 2009 :: 07:45
Печать  
Все, заработало  Улыбка
Всем большое спасибо
Вылетало на колонке пиктограммы, нормально работает:
Код
Выбрать все
	ФормаРасш = СоздатьОбъект("РасширениеФормы");
	ФормаРасш.УстановитьФорму(Форма);
	Для Х = 0 По ФормаРасш.КоличествоАтрибутов() - 1 Цикл
		Если СокрЛП(ФормаРасш.ПолучитьАтрибут(Х).Заголовок)="" тогда
			Продолжить;
		КонецЕсли;
		Сообщить(ФормаРасш.ПолучитьАтрибут(Х).Заголовок);
		ФормаРасш.ПолучитьАтрибут(Х).Заголовок="Опа";
	КонецЦикла;  

  
Наверх
 
IP записан
 
Eprst
God Member
*****
Отсутствует



Сообщений: 3396
Зарегистрирован: 08. Октября 2007
Re: Заголовок колонки многострочной части
Ответ #12 - 02. Июня 2009 :: 08:03
Печать  
Вот 94-ый релиз, если что..
http://www.1cpp.ru/forumfiles/Attachments/fe_test_006.zip
  
Наверх
 
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Заголовок колонки многострочной части
Ответ #13 - 02. Июня 2009 :: 09:04
Печать  
А что нового в 94 ? что-то я пропустил его выход? Улыбка
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
Eprst
God Member
*****
Отсутствует



Сообщений: 3396
Зарегистрирован: 08. Октября 2007
Re: Заголовок колонки многострочной части
Ответ #14 - 02. Июня 2009 :: 09:12
Печать  
Я чесно говоря не помню, это АЛьФ вроде как "дырки" закрывал..
можно поиском найти ветку, где он выкладывал (или не он ?) не помню.
  
Наверх
 
IP записан
 
vip
1c++ power user
Отсутствует



Сообщений: 1570
Зарегистрирован: 19. Мая 2006
Re: Заголовок колонки многострочной части
Ответ #15 - 02. Июня 2009 :: 11:13
Печать  
Eprst писал(а) 02. Июня 2009 :: 09:12:
Я чесно говоря не помню, это АЛьФ вроде как "дырки" закрывал..
можно поиском найти ветку, где он выкладывал (или не он ?) не помню.

Смутно вспоминается исправление достаточно редкой ситуации.

При открытом ЕДИНСТВЕННОМ модальном окне, в нем не работал перехват клавиш.
  
Наверх
ICQ  
IP записан
 
slider26
Senior Member
****
Отсутствует


I Love YaBB 2!

Сообщений: 256
Зарегистрирован: 01. Июня 2006
Re: Заголовок колонки многострочной части
Ответ #16 - 03. Июня 2009 :: 02:42
Печать  
artbear писал(а) 02. Июня 2009 :: 09:04:
А что нового в 94 ? что-то я пропустил его выход? Улыбка

Полагаю, что исправлялась вот эта ошибка Улыбка
http://www.1cpp.ru/forum/YaBB.pl?num=1227083045/0
И еще:
http://www.1cpp.ru/forum/YaBB.pl?num=1208156473/45#45
Пост 46
С тех пор, как я его написал, никакой реакции не последовало Печаль
Уважаемый Альф, ИМХО: полагаю, что релиз уже оттестирован и имеет смысл выложить его на Dorex Улыбка

  
Наверх
 
IP записан
 
Tanya__
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 1
Зарегистрирован: 17. Июля 2009
Re: Заголовок колонки многострочной части
Ответ #17 - 17. Июля 2009 :: 09:34
Печать  
А как можно сделать перенос строки в заголовке (т.е. чтобы заголовок колонки печатался в две-три строки) Улыбка
  
Наверх
 
IP записан
 
recop
Full Member
***
Отсутствует


1C++ rocks!

Сообщений: 235
Местоположение: Калуга
Зарегистрирован: 06. Июня 2017
Пол: Мужской
Re: Заголовок колонки многострочной части
Ответ #18 - 27. Июля 2019 :: 21:01
Печать  
Код
Выбрать все
	ФормаРасш = СоздатьОбъект("РасширениеФормы");
	ФормаРасш.УстановитьФорму(Форма);
	Для Х = 0 По ФормаРасш.КоличествоАтрибутов() - 1 Цикл
		Если СокрЛП(ФормаРасш.ПолучитьАтрибут(Х).Заголовок)="" тогда
			Продолжить;
		КонецЕсли;
		Сообщить(ФормаРасш.ПолучитьАтрибут(Х).Заголовок);
		ФормаРасш.ПолучитьАтрибут(Х).Заголовок="Опа";
	КонецЦикла;
 



Здорово! Но как отличить атрибуты принадлежащие именно многострочной части?
  
Наверх
 
IP записан
 
Переключение на Главную Страницу Страницы: [1] 
ОтправитьПечать