Переключение на Главную Страницу Страницы: 1 ОтправитьПечать
Горячая тема (более 10 ответов) Максимизация окон… (число прочтений - 3350 )
adm1nzoda
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 7
Зарегистрирован: 02. Июня 2010
Максимизация окон…
02. Июня 2010 :: 08:40
Печать  
Не как не получается Максимизировать окно. Вот что получается..
i5.fastpic.ru/big/2010/0602/8c/8d35f12d5396068d61541d5c7f9f618c.jpg

А вот программный код...
Код
Выбрать все
Процедура ПриОткрытии()
окно.СоздатьОбъект("Окна");
окно.Максимизировать(ФОРМА);
КонецПроцедуры
 



Как можно правильно Максимизировать окну?..
  
Наверх
 
IP записан
 
alyuev
God Member
*****
Отсутствует


Гражданин Вселенной

Сообщений: 807
Местоположение: Одесса
Зарегистрирован: 07. Декабря 2007
Пол: Мужской
Re: Максимизация окон…
Ответ #1 - 02. Июня 2010 :: 09:34
Печать  
Код
Выбрать все
Процедура ПослеСозданияФормы()
	Окно = СоздатьОбъект("Окна");
	Окно.Максимизировать(Форма);
КонецПроцедуры 



Обрати внимание на имя предопределенной процедуры.
  

1C 7.7.025; 1C++ 3.2.4.3; Formex 2.0.5.94; 1sqlite
Наверх
IP записан
 
adm1nzoda
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 7
Зарегистрирован: 02. Июня 2010
Re: Максимизация окон…
Ответ #2 - 02. Июня 2010 :: 09:41
Печать  
Уххх... Млин... Пол года не могу решить эту проблему... Спасибо... Озадачен
  
Наверх
 
IP записан
 
adm1nzoda
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 7
Зарегистрирован: 02. Июня 2010
Re: Максимизация окон…
Ответ #3 - 02. Июня 2010 :: 14:23
Печать  
Как теперь эту код прописать всему что есть?
  
Наверх
 
IP записан
 
Eprst
God Member
*****
Отсутствует



Сообщений: 3396
Зарегистрирован: 08. Октября 2007
Re: Максимизация окон…
Ответ #4 - 03. Июня 2010 :: 05:11
Печать  
adm1nzoda писал(а) 02. Июня 2010 :: 14:23:
Как теперь эту код прописать всему что есть?

Задействовать класс Перехватчик - самое простое.
  
Наверх
 
IP записан
 
АЛьФ
FormEx developer
1c++ developer
Отсутствует



Сообщений: 1532
Местоположение: Санкт-Петербург
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Максимизация окон…
Ответ #5 - 03. Июня 2010 :: 06:09
Печать  
Eprst писал(а) 03. Июня 2010 :: 05:11:
adm1nzoda писал(а) 02. Июня 2010 :: 14:23:
Как теперь эту код прописать всему что есть?

Задействовать класс Перехватчик - самое простое.

А в глобальнике не проще ту же предопределенную процедуру прописать?
  

FormEx developer
Наверх
www  
IP записан
 
adm1nzoda
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 7
Зарегистрирован: 02. Июня 2010
Re: Максимизация окон…
Ответ #6 - 03. Июня 2010 :: 06:11
Печать  
АЛьФ писал(а) 03. Июня 2010 :: 06:09:
Eprst писал(а) 03. Июня 2010 :: 05:11:
adm1nzoda писал(а) 02. Июня 2010 :: 14:23:
Как теперь эту код прописать всему что есть?

Задействовать класс Перехватчик - самое простое.

А в глобальнике не проще ту же предопределенную процедуру прописать?

Вот я и спрашиваю, как записать в глобалку?..
  
Наверх
 
IP записан
 
hibico
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 7
Зарегистрирован: 28. Мая 2010
Re: Максимизация окон…
Ответ #7 - 03. Июня 2010 :: 06:13
Печать  
adm1nzoda писал(а) 02. Июня 2010 :: 14:23:
Как теперь эту код прописать всему что есть?

В глобальном модуле:
Код
Выбрать все
Процедура ПослеСозданияФормы(АкФорма)
	Окно = СоздатьОбъект("Окна");
	Окно.Максимизировать(АкФорма);
КонецПроцедуры
 

  
Наверх
 
IP записан
 
adm1nzoda
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 7
Зарегистрирован: 02. Июня 2010
Re: Максимизация окон…
Ответ #8 - 03. Июня 2010 :: 06:17
Печать  
А в документах что надо?... В глобалке написал, но еще в документах надо приписать? не так ли?..
  
Наверх
 
IP записан
 
Eprst
God Member
*****
Отсутствует



Сообщений: 3396
Зарегистрирован: 08. Октября 2007
Re: Максимизация окон…
Ответ #9 - 03. Июня 2010 :: 06:19
Печать  
adm1nzoda писал(а) 03. Июня 2010 :: 06:17:
А в документах что надо?... В глобалке написал, но еще в документах надо приписать? не так ли?..


Нет. больше нечего не нужно.
  
Наверх
 
IP записан
 
adm1nzoda
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 7
Зарегистрирован: 02. Июня 2010
Re: Максимизация окон…
Ответ #10 - 03. Июня 2010 :: 06:36
Печать  
Eprst писал(а) 03. Июня 2010 :: 06:19:
adm1nzoda писал(а) 03. Июня 2010 :: 06:17:
А в документах что надо?... В глобалке написал, но еще в документах надо приписать? не так ли?..


Нет. больше нечего не нужно.


Не работает... Печаль
  
Наверх
 
IP записан
 
Eprst
God Member
*****
Отсутствует



Сообщений: 3396
Зарегистрирован: 08. Октября 2007
Re: Максимизация окон…
Ответ #11 - 03. Июня 2010 :: 06:56
Печать  
Ну, так сделай
Код
Выбрать все
Процедура ПослеСозданияФормы(АкФорма) Экспорт //в глобальничке
	РасшФ = СоздатьОбъект("РасширениеФормы");
	РасшФ.УстановитьФорму(АкФорма.Форма);
	РасшФ.Максимизирована=1;
КонецПроцедуры
 



или так:

Код
Выбрать все
Процедура ПослеСозданияФормы(АкФорма) Экспорт
	Окна = СоздатьОбъект("Окна");
	Окна.Максимизировать(АкФорма.Форма);
КонецПроцедуры 

  
Наверх
 
IP записан
 
adm1nzoda
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 7
Зарегистрирован: 02. Июня 2010
Re: Максимизация окон…
Ответ #12 - 03. Июня 2010 :: 06:59
Печать  
Мда.. Спасибо.. Теперь сработало..  Подмигивание
  
Наверх
 
IP записан
 
Переключение на Главную Страницу Страницы: 1
ОтправитьПечать