Переключение на Главную Страницу Страницы: 1 2 [3]  ОтправитьПечать
Очень популярная тема (более 25 ответов) Как установить многострочность у реквизита строка? (число прочтений - 11500 )
Leonid
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 4
Местоположение: Nikopol (Ukraine)
Зарегистрирован: 05. Мая 2019
Пол: Мужской
Re: Как установить многострочность у реквизита строка?
Ответ #30 - 25. Мая 2019 :: 09:22
Печать  
АЛьФ писал(а) 06. Мая 2019 :: 06:47:
Вместо ВвестиСтроку сделать обработку с тестовым реквизитом на форме с установленным флагом многострочности.
А можно разъяснить чем отличается реквизит в форме с установленным флагом многстрочности и такой же реквизит только в обработке?
  
Наверх
IP записан
 
Leonid
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 4
Местоположение: Nikopol (Ukraine)
Зарегистрирован: 05. Мая 2019
Пол: Мужской
Re: Как установить многострочность у реквизита строка?
Ответ #31 - 25. Мая 2019 :: 09:25
Печать  
alyuev писал(а) 06. Мая 2019 :: 08:24:
Сделай так:

Код
Выбрать все
ВвестиСтроку(Инф, "Введите значение ", 0, 1,) 




К сожалению так не сработало.  Хоть и реквизит формы имеет флаг многострочности. Все также в окне текст в одну длинную строку и выходит за размеры окна ввода.
  
Наверх
IP записан
 
alyuev
God Member
*****
Отсутствует


Гражданин Вселенной

Сообщений: 807
Местоположение: Одесса
Зарегистрирован: 07. Декабря 2007
Пол: Мужской
Re: Как установить многострочность у реквизита строка?
Ответ #32 - 29. Мая 2019 :: 08:48
Печать  
Сделал простую форму с модулем:
Код
Выбрать все
Процедура ИзмМногостр(мнТекст) Экспорт
	Стр=мнТекст;
	Если ВвестиСтроку(Стр,"Введите новый текст",0,1)=1 Тогда //Вместо 0 корректно срабатывает и число длины
		мнТекст=Стр;
	КонецЕсли;
КонецПроцедуры

//*******************************************
Процедура Сформировать()
	ИзмМногостр(мойТекст);
КонецПроцедуры 



На форме - текстовый реквизит "мойТекст". Экспериментировал как с установленным признаком многострочности, так и без. Нормально дает ввести многострочный текст.
  

1C 7.7.025; 1C++ 3.2.4.3; Formex 2.0.5.94; 1sqlite
Наверх
IP записан
 
avgreen
Senior Member
****
Отсутствует



Сообщений: 254
Местоположение: Украина, Кривой Рог
Зарегистрирован: 20. Октября 2006
Пол: Мужской
Re: Как установить многострочность у реквизита строка?
Ответ #33 - 28. Июня 2019 :: 07:38
Печать  
alyuev писал(а) 29. Мая 2019 :: 08:48:
Сделал простую форму с модулем:
Код
Выбрать все
Процедура ИзмМногостр(мнТекст) Экспорт
	Стр=мнТекст;
	Если ВвестиСтроку(Стр,"Введите новый текст",0,1)=1 Тогда //Вместо 0 корректно срабатывает и число длины
		мнТекст=Стр;
	КонецЕсли;
КонецПроцедуры

//*******************************************
Процедура Сформировать()
	ИзмМногостр(мойТекст);
КонецПроцедуры 



На форме - текстовый реквизит "мойТекст". Экспериментировал как с установленным признаком многострочности, так и без. Нормально дает ввести многострочный текст.


Насколько я понял не работает не многострочность, а автоперенос при многострочности. Так?
Тогда задачу нужно ставить правильно. Только тогда получается правильный ответ  Улыбка
  
Наверх
ICQ  
IP записан
 
Leonid
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 4
Местоположение: Nikopol (Ukraine)
Зарегистрирован: 05. Мая 2019
Пол: Мужской
Re: Как установить многострочность у реквизита строка?
Ответ #34 - 15. Сентября 2019 :: 09:28
Печать  
[/quote]Насколько я понял не работает не многострочность, а автоперенос при многострочности. Так?
Тогда задачу нужно ставить правильно. Только тогда получается правильный ответ  Улыбка [/quote]
Да, так и есть. Именно нужен автоперенос текста в размере окна.  Улыбка
  
Наверх
IP записан
 
Переключение на Главную Страницу Страницы: 1 2 [3] 
ОтправитьПечать