Переключение на Главную Страницу Страницы: 1 2 3 [4]  ОтправитьПечать
Очень популярная тема (более 25 ответов) Статья о использовании прямых запросов (число прочтений - 116057 )
arpeko
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 7
Зарегистрирован: 11. Ноября 2010
Re: Статья о использовании прямых запросов
Ответ #45 - 12. Ноября 2010 :: 08:19
Печать  
Получить параметр...
  
Наверх
 
IP записан
 
Dmitry The Wing
God Member
*****
Отсутствует


1C++ rocks!

Сообщений: 839
Местоположение: Где-то в Сибири
Зарегистрирован: 18. Августа 2009
Пол: Мужской
Re: Статья о использовании прямых запросов
Ответ #46 - 12. Ноября 2010 :: 08:41
Печать  
ой ... это перечисление ... его никак нельзя удаленно получить, т.к. имя хранится только в метаданных ... я решал это путем копирования перечислений, т.к. это обычно неизменные значения.
Запросом получал порядковый номер, а по нему уже находил это значение локально.
  
Наверх
 
IP записан
 
vivm
Full Member
***
Отсутствует



Сообщений: 159
Местоположение: Новосибирск
Зарегистрирован: 26. Мая 2006
Пол: Мужской
Re: Статья о использовании прямых запросов
Ответ #47 - 12. Ноября 2010 :: 10:14
Печать  
Код
Выбрать все
|, case when $Спр.ТипНоменклатуры = $Перечисление.ТипыНоменклатуры.Продукция then 'Продукция'
|		when $Спр.ТипНоменклатуры = $Перечисление.ТипыНоменклатуры.Товар then 'Товар'
|	 else '' end as ТипНоменклатуры 



  
Наверх
ICQ  
IP записан
 
Dmitry The Wing
God Member
*****
Отсутствует


1C++ rocks!

Сообщений: 839
Местоположение: Где-то в Сибири
Зарегистрирован: 18. Августа 2009
Пол: Мужской
Re: Статья о использовании прямых запросов
Ответ #48 - 16. Ноября 2010 :: 02:25
Печать  
vivm писал(а) 12. Ноября 2010 :: 10:14:
case
Это хорошо, когда у перечисления мало значений, а когда много - проще скопировать...
К тому же, его использование явно не будет ограничено только запросом. Коль уже видна затребованность получения - значит перечисление будет использовано и где-то еще в конфе.
  
Наверх
 
IP записан
 
sml
Full Member
***
Отсутствует


I Love 1С++!

Сообщений: 186
Зарегистрирован: 28. Февраля 2008
Re: Статья о использовании прямых запросов
Ответ #49 - 09. Февраля 2011 :: 10:17
Печать  
Можно в конфе, откуда копируешь, добавить справочник "ОбъектыМетаданных" и туда заполнить всю нужную информацию по внутренним ИД объектов, а затем прямым запросом join-ить этот справочник  по ИД нужных объектов, и из него тащить представление объекта.
  
Наверх
 
IP записан
 
Garry
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 2
Зарегистрирован: 10. Декабря 2011
Re: Статья о использовании прямых запросов
Ответ #50 - 10. Декабря 2011 :: 13:44
Печать  
  Друзья, может кто из Вас простыми доступными для физика-математика словами (опыт 5 лет в 1с7) объяснить схему построения ПРЯМОГО ЗАПРОСА в ДБФ-базе с помощью 1с++ ?
(что скачать, куда поставить и пр.)
  К примеру есть простенький запрос по долгам поставщикам из Регистра.ПОСТАВЩИКИ (ТиС) - как его "переделать" в ПРЯМОЙ ?

  Запрос таков -

Процедура Сформировать()      
     
     Запрос = СоздатьОбъект("Запрос");
     ТекстЗапроса =
     "//{{ЗАПРОС(Сформировать)
     |Период с ДатаНачала по ДатаКонца;
     |Контрагент = Регистр.Поставщики.Договор.Владелец;
     |Долг = Регистр.Поставщики.СуммаРуб;
     |Док  = Регистр.Поставщики.КредДокумент;
     |Функция КонОст = КонОст(Долг);
     |Группировка Контрагент;  
     |";  

     // Если ошибка в запросе, то выход из процедуры    
     Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
           Сообщить("Ошибка в запросе");
           Возврат;
     КонецЕсли;    
     
     Пока Запрос.Группировка(1)=1 Цикл
         
           Контр = Запрос.КонтрАгент;
           СуммаДолга  = Запрос.КонОст;
           Докум = Запрос.Док;
           
           Сообщить("агент ----- "+Контр);
           Сообщить("долг = "+СуммаДолга);
           Сообщить("документ = "+Докум);
                       
     КонецЦикла;
     
КонецПроцедуры
//************************************************
Буду премного благодарен за добрый совет.
В свою очередь могу быть полезен практически любыми консультациями по математике-физике.
Воскресенский Игорь.
garry366@mail.ru
Улыбка
  
Наверх
 
IP записан
 
Garry
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 2
Зарегистрирован: 10. Декабря 2011
Re: Статья о использовании прямых запросов
Ответ #51 - 10. Декабря 2011 :: 13:48
Печать  
   Друзья, может кто из Вас простыми доступными для физика-математика словами (опыт 5 лет в 1с7) объяснить схему построения ПРЯМОГО ЗАПРОСА в ДБФ-базе с помощью 1с++ ?
(что скачать, куда поставить и пр.)
   К примеру есть простенький запрос по долгам поставщикам из Регистра.ПОСТАВЩИКИ (ТиС) - как его "переделать" в ПРЯМОЙ ?

   Запрос таков -

Процедура Сформировать()      
     
     Запрос = СоздатьОбъект("Запрос");
     ТекстЗапроса =
     "//{{ЗАПРОС(Сформировать)
     |Период с ДатаНачала по ДатаКонца;
     |Контрагент = Регистр.Поставщики.Договор.Владелец;
     |Долг = Регистр.Поставщики.СуммаРуб;
     |Док  = Регистр.Поставщики.КредДокумент;
     |Функция КонОст = КонОст(Долг);
     |Группировка Контрагент; 
     |";   

     // Если ошибка в запросе, то выход из процедуры   
     Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
           Сообщить("Ошибка в запросе");
           Возврат;
     КонецЕсли;   
     
     Пока Запрос.Группировка(1)=1 Цикл
        
           Контр = Запрос.КонтрАгент;
           СуммаДолга  = Запрос.КонОст;
           Докум = Запрос.Док;
           
           Сообщить("агент ----- "+Контр);
           Сообщить("долг = "+СуммаДолга);
           Сообщить("документ = "+Докум);
                       
     КонецЦикла;
     
КонецПроцедуры
//************************************************
Буду премного благодарен за добрый совет.
В свою очередь могу быть полезен практически любыми консультациями по математике-физике.
Воскресенский Игорь.
garry366@mail.ru
Улыбка
  
Наверх
 
IP записан
 
Eprst
God Member
*****
Отсутствует



Сообщений: 3397
Зарегистрирован: 08. Октября 2007
Re: Статья о использовании прямых запросов
Ответ #52 - 11. Декабря 2011 :: 15:23
Печать  
Скачиваешь статью из первого сообщения и делаешь для начала, по образу и подобию.
Потом читаешь про использование индексов в фоксе, и переписываешь получившийся запрос.
А вот когда надоесть играться с фоксом, смотришь в сторону 1sqlite.
Как-то так.
  
Наверх
 
IP записан
 
Переключение на Главную Страницу Страницы: 1 2 3 [4] 
ОтправитьПечать