Опрос
Опрос Тема Опроса: Нужен ли функционал создания тулбаров в компоненте



« Последняя модификация: mvgfirst : 20. Декабря 2007 :: 18:33 »
Переключение на Главную Страницу Страницы: 1 ... 12 13 [14] 15  ОтправитьПечать
Очень популярная тема (более 25 ответов) [RWidjets] Динамическое меню программы (число прочтений - 109509 )
al_zzz
Senior Member
****
Отсутствует


1C++ ->

Сообщений: 361
Местоположение: Барнаул
Зарегистрирован: 05. Сентября 2009
Пол: Мужской
Re: [RWidjets] Динамическое меню программы
Ответ #195 - 02. Апреля 2010 :: 08:45
Печать  
А есть функционал, чтоб панель обновлять или зарывать? Я, чет, в документации не нашел.
Если нет, то можно ли его как-то добавить - очень нужен!
  

Каждая система проходит три стадии:&&1) Шумиха&&2) Неразбериха&&3) Поиск виновных (собственно, рабочий процесс)&&4) Наказание невиновных&&5) Награждение непричастных&& В.М. Глушков
Наверх
 
IP записан
 
al_zzz
Senior Member
****
Отсутствует


1C++ ->

Сообщений: 361
Местоположение: Барнаул
Зарегистрирован: 05. Сентября 2009
Пол: Мужской
Re: [RWidjets] Динамическое меню программы
Ответ #196 - 02. Апреля 2010 :: 09:39
Печать  
Поделитесь примером, как к элементу тулбара обратиться?
  

Каждая система проходит три стадии:&&1) Шумиха&&2) Неразбериха&&3) Поиск виновных (собственно, рабочий процесс)&&4) Наказание невиновных&&5) Награждение непричастных&& В.М. Глушков
Наверх
 
IP записан
 
al_zzz
Senior Member
****
Отсутствует


1C++ ->

Сообщений: 361
Местоположение: Барнаул
Зарегистрирован: 05. Сентября 2009
Пол: Мужской
Re: [RWidjets] Динамическое меню программы
Ответ #197 - 08. Июня 2010 :: 04:26
Печать  
А можно как-нибудь панель не ниже всех панелей новой строчкой, а рядом, если есть место или кнопку динамически на
существующую панель добавить?
  

Каждая система проходит три стадии:&&1) Шумиха&&2) Неразбериха&&3) Поиск виновных (собственно, рабочий процесс)&&4) Наказание невиновных&&5) Награждение непричастных&& В.М. Глушков
Наверх
 
IP записан
 
nixstill
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 14
Зарегистрирован: 19. Января 2011
Re: [RWidjets] Динамическое меню программы
Ответ #198 - 19. Января 2011 :: 22:47
Печать  
Про включение функционала RWidjets в ФормЭкс. Проясните ситуацию... Будет не будет?
  
Наверх
 
IP записан
 
al_zzz
Senior Member
****
Отсутствует


1C++ ->

Сообщений: 361
Местоположение: Барнаул
Зарегистрирован: 05. Сентября 2009
Пол: Мужской
Re: [RWidjets] Динамическое меню программы
Ответ #199 - 20. Января 2011 :: 03:14
Печать  
nixstill писал(а) 19. Января 2011 :: 22:47:
Про включение функционала RWidjets в ФормЭкс. Проясните ситуацию... Будет не будет?

Я так понимаю, проектом давно никто не занимается. Поэтому, скорее всего ждать нечего.
  

Каждая система проходит три стадии:&&1) Шумиха&&2) Неразбериха&&3) Поиск виновных (собственно, рабочий процесс)&&4) Наказание невиновных&&5) Награждение непричастных&& В.М. Глушков
Наверх
 
IP записан
 
nixstill
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 14
Зарегистрирован: 19. Января 2011
Re: [RWidjets] Динамическое меню программы
Ответ #200 - 20. Января 2011 :: 09:13
Печать  
Плачущий Жаль конечно, мне бы было интересно такое "слияние". Пользуюсь и тем и другим.
  
Наверх
 
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: [RWidjets] Динамическое меню программы
Ответ #201 - 20. Января 2011 :: 13:37
Печать  
nixstill писал(а) 19. Января 2011 :: 22:47:
Про включение функционала RWidjets в ФормЭкс. Проясните ситуацию... Будет не будет?

А зачем это нужно? что должно улучшиться?
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
CaBaT
God Member
*****
Отсутствует


I Love YaBB 2!

Сообщений: 718
Местоположение: Санкт-Петербург
Зарегистрирован: 26. Октября 2007
Пол: Мужской
Re: [RWidjets] Динамическое меню программы
Ответ #202 - 20. Января 2011 :: 13:44
Печать  
artbear писал(а) 20. Января 2011 :: 13:37:
А зачем это нужно? что должно улучшиться?

Поддерживаю!

В течении наверное пары лет использовал вполне успешно, а с помощью chessman-а даже в свое время удалось прикрутить всплывающие подсказки к тулбару (это правда уже к RTooltips относится)
  
Наверх
 
IP записан
 
Boog
Junior Member
**
Отсутствует



Сообщений: 95
Местоположение: Винница
Зарегистрирован: 23. Февраля 2009
Пол: Мужской
Re: [RWidjets] Динамическое меню программы
Ответ #203 - 28. Января 2011 :: 17:11
Печать  
Уважаемые!
Есть непонятное поведение компоненты.
Добавляю команду в меню Сервис:
Код
Выбрать все
мнСервис.ДобавитьКоманду("Права","Права ","ОткрытьФорму(""Справочник.Права.ФормаСписка"")"); 


Пункт меню появляется, но реакции на нажатие нет. Если определяю процедуру ПриПолученииКоманды(Команда,БлокировкаКоманды) в глобальнике (присоединен формексом), то его тоже никто никогда не вызывает.
Подскажите, что я делаю не правильно!
  
Наверх
 
IP записан
 
avgreen
Senior Member
****
Отсутствует



Сообщений: 254
Местоположение: Украина, Кривой Рог
Зарегистрирован: 20. Октября 2006
Пол: Мужской
Re: [RWidjets] Динамическое меню программы
Ответ #204 - 03. Февраля 2011 :: 14:26
Печать  
Boog писал(а) 28. Января 2011 :: 17:11:
Уважаемые!
Есть непонятное поведение компоненты.
Добавляю команду в меню Сервис:
Код
Выбрать все
мнСервис.ДобавитьКоманду("Права","Права ","ОткрытьФорму(""Справочник.Права.ФормаСписка"")"); 


Пункт меню появляется, но реакции на нажатие нет.
Странно! У меня практически так-же,  и все работает
Код
Выбрать все
  мнСервис.ДобавитьКоманду("РедактироватьДопМеню", "Редактировать меню ""Доп. возможности""", epAdmin.ert"");");
 

Разве что точки с запятой у тебя в конце команды нету..... неужели критично?
Цитата:
Если определяю процедуру ПриПолученииКоманды(Команда,БлокировкаКоманды) в глобальнике (присоединен формексом), то его тоже никто никогда не вызывает.
Подскажите, что я делаю не правильно!

А данная процедура как я понял для отлова стандартных пунктов меня. И она у меня тоже нормально работает
Код
Выбрать все
// Событие ВК RWidjets
Процедура ПриПолученииКоманды(пКоманда, пЗаблокироватьКоманду)
	Перем лЖурнал;

	Если пКоманда = КомандыИнтерфейса.ИзменитьВремяДокумента Тогда
		Сервис = СоздатьОбъект("Сервис");
		Если Сервис.АктивныйКонтекст(лЖурнал) = 1 тогда
			Если ТипЗначенияСтр(лЖурнал) = "ГрупповойКонтекст" Тогда
				ФормаРасш=СоздатьОбъект("РасширениеФормы");
				ФормаРасш.УстановитьФорму(лЖурнал.Форма);
				ТипОбъекта = ФормаРасш.ТипОбъекта();
				Если ТипОбъекта = "Журнал" Тогда
					Если глИспользоватьУчетПоСменам(лЖурнал.ТекущийДокумент) = 1 Тогда // Для остальніх документов стандартный диалог "Время документа"
						пЗаблокироватьКоманду = 1;
						//*avgreen@molvest.org.ua, 2009-11-24 08:38:19
						//						ОткрытьФормуМодально("Отчет", лЖурнал.ТекущийДокумент, КаталогИБ()+"ExtForms\В разработке\Время документа.ert");
						// -------- заменено на:
						ОткрытьФормуМодально("Обработка.ВремяДокумента", лЖурнал.ТекущийДокумент);
						//\avgreen@molvest.org.ua, 2009-11-24 08:38:19
					КонецЕсли;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
	//Иначе
	//	Сообщить(пКоманда);
	КонецЕсли;
КонецПроцедуры
 

  
Наверх
ICQ  
IP записан
 
Boog
Junior Member
**
Отсутствует



Сообщений: 95
Местоположение: Винница
Зарегистрирован: 23. Февраля 2009
Пол: Мужской
Re: [RWidjets] Динамическое меню программы
Ответ #205 - 04. Февраля 2011 :: 10:04
Печать  
Странно. Разница только в том, что я делаю это не в глобальнике. Я инициализирую пункт меню в обработке, которая вызывается из ПриНачалеРаботыСистемы. Там же я подключаю глобальный модуль, в котором определена процедура ПриПолученииКоманды. И не работает ни одно, ни другое... Печаль
Что я могу предпринять?

P.S. Мне очень не хотелось бы выносить это все в основной глобальник...
  
Наверх
 
IP записан
 
avgreen
Senior Member
****
Отсутствует



Сообщений: 254
Местоположение: Украина, Кривой Рог
Зарегистрирован: 20. Октября 2006
Пол: Мужской
Re: [RWidjets] Динамическое меню программы
Ответ #206 - 04. Февраля 2011 :: 12:00
Печать  
Boog писал(а) 04. Февраля 2011 :: 10:04:
Странно. Разница только в том, что я делаю это не в глобальнике. Я инициализирую пункт меню в обработке, которая вызывается из ПриНачалеРаботыСистемы. Там же я подключаю глобальный модуль, в котором определена процедура ПриПолученииКоманды. И не работает ни одно, ни другое... Печаль
Ну то что "другое" не работает я даже не удивляюсь. Предопределенные процедуры в подключаемом глобальнике могут и не работать. Как говорится "никто и не обещал" Улыбка
Цитата:
Что я могу предпринять?
PS. Мне очень не хотелось бы выносить это все в основной глобальник...

А ты таки попробуй! Если причина именно в этом то другого выхода нету. Ну можешь еще попробовать порядком загрузки ВК "поиграться"
  
Наверх
ICQ  
IP записан
 
Boog
Junior Member
**
Отсутствует



Сообщений: 95
Местоположение: Винница
Зарегистрирован: 23. Февраля 2009
Пол: Мужской
Re: [RWidjets] Динамическое меню программы
Ответ #207 - 04. Февраля 2011 :: 12:35
Печать  
Работает только: если компонента загружена первой в основном глобальнике и создание меню описано там же!
Другие варианты у меня не взлетели.
Но, вот тут http://www.1cpp.ru/forum/YaBB.pl?num=1162249850/37#37 kms написал, что 1cpp нужно грузить первым.

Вот такой вот результат...
  
Наверх
 
IP записан
 
kms
1c++ power user
1c++ moderator
Отсутствует


я хочу, чтоб сюда проложили
дорогу оттуда...

Сообщений: 4632
Зарегистрирован: 19. Мая 2006
Re: [RWidjets] Динамическое меню программы
Ответ #208 - 04. Февраля 2011 :: 18:51
Печать  
С тех пор много воды утекло -> сейчас обосновывать необходимость какого-то конкретного порядока я не готов.
  

De quelle planète es-tu?
Наверх
 
IP записан
 
zk96
Senior Member
****
Отсутствует


1C++ rocks!

Сообщений: 320
Местоположение: Киев
Зарегистрирован: 15. Ноября 2009
Пол: Мужской
Re: [RWidjets] Динамическое меню программы
Ответ #209 - 04. Февраля 2011 :: 21:59
Печать  
Boog писал(а) 04. Февраля 2011 :: 12:35:
Работает только: если компонента загружена первой в основном глобальнике и создание меню описано там же!
...[/b]

У меня загружается ПОСЛЕ 1С++ и нормально  работает событие ПриПолученииКоманды
  
Наверх
 
IP записан
 
Переключение на Главную Страницу Страницы: 1 ... 12 13 [14] 15 
ОтправитьПечать