Переключение на Главную Страницу Страницы: 1 ... 12 13 [14] 15 16 ... 18 ОтправитьПечать
Очень популярная тема (более 25 ответов) Революция - возможность добавления атрибутов!! (число прочтений - 173602 )
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Революция - возможность добавления атрибутов!!
Ответ #195 - 10. Октября 2007 :: 08:44
Печать  
lustin писал(а) 09. Октября 2007 :: 12:56:
Есть какие нибудь новости, в частности -
работает ли возможность задания Формулы у Статика МнЧ?

а также существует ли возможность управлять шириной этой колонки


Добавление атрибутов в табличную часть пока не работает или работает очень плохо Печаль
Формула у статика МнЧ, добавленного в конфигураторе, менять можно.
Насчет ширины не знаю.
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
Radigosh
YaBB Newbies
*
Отсутствует


I Love YaBB 2!

Сообщений: 2
Зарегистрирован: 12. Октября 2007
Re: Революция - возможность добавления атрибутов!!
Ответ #196 - 12. Октября 2007 :: 11:56
Печать  
Подскажите пожалуйста, доступен ли атрибут ИмеетКнопкуВыбора для созданного атрибута формы типа Edit на запись?
Дело в том что на форуме и впримерах вижу его использование, но вот такой код:
Код
Выбрать все
Процедура ПослеОткрытия()
	РасшФормы = СоздатьОбъект("РасширениеФормы");
	Атрибут = РасшФормы.ДобавитьАтрибут("НовыйЭдит",2,"Число");
	Атрибут.УстановитьКоординаты(10,10,40,20);
	Форма.НовыйЭдит.НазначитьТип("Число",5,2);
	Атрибут.Доступность = 1;
	Атрибут.ИмеетКнопкуВыбора = 0;
	Форма.Обновить(0);
КонецПроцедуры 


не работает. В смысле педалька есть не зависимо от присвоения атрибуту значения.
ФормЭкс 2.0.5.76
1с++ 2.5.0.3
  
Наверх
 
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Революция - возможность добавления атрибутов!!
Ответ #197 - 23. Октября 2007 :: 09:20
Печать  
В общем, Революция продолжается !! Улыбка  Смех
На днях в ФормЕкс будет добавлена новая фича - вставка статиков в штатные табличные части 1С


Огромное спасибо Диме Трапезникову aka trad. Практически весь код его, мое участие по сравнению с ним совсем махонькое.

также будут добавлены фичи
1) выравнивание текста в атрибутах
2) установка заголовка колонки ТЧ
3) поправлена работа подсказок и описаний для любых атрибутов, как существующих, так и вновь добавленных
4) к новым атрибутам можно будет обращаться через штатные Форма.НовыйАтрибут

Ура!
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
Arta
1c++ power user
Отсутствует



Сообщений: 2537
Местоположение: Нижний Новгород
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Революция - возможность добавления атрибутов!!
Ответ #198 - 23. Октября 2007 :: 09:53
Печать  
Обоим по бочонку пива при заезде ко мне в Нижний Новгород Улыбка
  
Наверх
 
IP записан
 
vip
1c++ power user
Отсутствует



Сообщений: 1570
Зарегистрирован: 19. Мая 2006
Re: Революция - возможность добавления атрибутов!!
Ответ #199 - 23. Октября 2007 :: 12:32
Печать  
artbear писал(а) 23. Октября 2007 :: 09:20:
В общем, Революция продолжается !! Улыбка  Смех
На днях в ФормЕкс будет добавлена новая фича - вставка статиков в штатные табличные части 1С


Огромное спасибо Диме Трапезникову aka trad. Практически весь код его, мое участие по сравнению с ним совсем махонькое.

также будут добавлены фичи
1) выравнивание текста в атрибутах
2) установка заголовка колонки ТЧ
3) поправлена работа подсказок и описаний для любых атрибутов, как существующих, так и вновь добавленных
4) к новым атрибутам можно будет обращаться через штатные Форма.НовыйАтрибут

Ура!


Когда попробуем (успешно), тогда "Ура!" и грянем Очень довольный
Ты бы выкладывал потестить здесь, быстрей бы отладил. А уже после местной отладки, на сайт к АЛьФу.
  
Наверх
ICQ  
IP записан
 
Radigosh
YaBB Newbies
*
Отсутствует


I Love YaBB 2!

Сообщений: 2
Зарегистрирован: 12. Октября 2007
Re: Революция - возможность добавления атрибутов!!
Ответ #200 - 24. Октября 2007 :: 12:28
Печать  
Цитата:
Подскажите пожалуйста, доступен ли атрибут ИмеетКнопкуВыбора для созданного атрибута формы типа Edit на запись?
Дело в том что на форуме и впримерах вижу его использование, но вот такой код:
skiped

Вообщем если комуто еще интересен этот вопрос.
То по умолчанию атрибут на форме создается без педальки, а при присвоении "ИмеетКнопкуВыбора" любого значения педалька появляется.
Оно так и должно быть или это баг? Неохота потом код перекапывать.
  
Наверх
 
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Революция - возможность добавления атрибутов!!
Ответ #201 - 25. Октября 2007 :: 11:36
Печать  
Посмотрю, что можно сделать.
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
KudrC
YaBB Newbies
*
Отсутствует


I Love YaBB 2!

Сообщений: 1
Зарегистрирован: 12. Октября 2007
Re: Революция - возможность добавления атрибутов!!
Ответ #202 - 26. Октября 2007 :: 22:13
Печать  
Вопрос по реквизиту на форме типа строка (для ввода и редактирования), не удается назначить неограниченную длинну и признак многострочности.
Будет ли решена данная проблема?
  
Наверх
 
IP записан
 
vip
1c++ power user
Отсутствует



Сообщений: 1570
Зарегистрирован: 19. Мая 2006
Re: Революция - возможность добавления атрибутов!!
Ответ #203 - 30. Октября 2007 :: 12:54
Печать  
to artbear
http://www.1cpp.ru/forum/YaBB.pl?num=1178269183/202#199
Когда "Ура!" кричать будем? Улыбка
  
Наверх
ICQ  
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Революция - возможность добавления атрибутов!!
Ответ #204 - 30. Октября 2007 :: 13:40
Печать  
Пока есть проблемы с добавлением статиков в ТЧ Документа и не до конца проверен код Форма.НовыйАтрибут Печаль
В формах списков справочников и журналах документов добавление статиков в ТЧ нормально работает.
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
Arta
1c++ power user
Отсутствует



Сообщений: 2537
Местоположение: Нижний Новгород
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Революция - возможность добавления атрибутов!!
Ответ #205 - 05. Декабря 2007 :: 15:04
Печать  
Артур, не проходи мимо Улыбка
http://www.1cpp.ru/bugs/show_bug.cgi?id=3425
  
Наверх
 
IP записан
 
Boris_1c
Full Member
***
Отсутствует


I Love YaBB 2!

Сообщений: 127
Зарегистрирован: 29. Января 2007
Re: Революция - возможность добавления атрибутов!!
Ответ #206 - 03. Мая 2008 :: 08:01
Печать  
artbear писал(а) 10. Августа 2007 :: 08:45:
По договоренности с Алексеем выкладываю ВК FormEx сборка 59+, т.е. это сборка соответствует сборке 59 + мои изменения по ДобавитьАтрибут/ДобавитьАтрибутСФормулой.

Прямой линк http://webfile.ru/1493635


файлик отсутствует - можно куда-нить продублировать ?

Скиньте плиз работающий релиз - что б значение добавленного реквизита нормально возвращалось. Все что возвращает - "неизвестныйОбъект" и алес FormEx из первого поста и с дорекса..
  
Наверх
 
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Революция - возможность добавления атрибутов!!
Ответ #207 - 04. Мая 2008 :: 04:59
Печать  
Качай последнюю официальную ФормЕкс с дорекс.ру - весь функционал давно там.
Если не получится, приведи пример теста, который работает неверно.
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
Boris_1c
Full Member
***
Отсутствует


I Love YaBB 2!

Сообщений: 127
Зарегистрирован: 29. Января 2007
Re: Революция - возможность добавления атрибутов!!
Ответ #208 - 07. Мая 2008 :: 06:15
Печать  
FormEx 2.0.5.86

новая кнопка - справочник
Код: Сообщить(НоваяКнопка1);

Выдает ошибку
Сообщить(НоваяКнопка1<<?>>);
Переменная не определена (НоваяКнопка1)

Код: Сообщить(Форма.ПолучитьАтрибут("НоваяКнопка1"))

Выполняется без ошибки и выдает: НеизвестныйОбъект

Добавляю на форму так:
Код
Выбрать все
Функция ДобавитьАтрибут(ИмяАтрибута, ТипАтрибута, Смещение, ТипВид  = "",гРасширениеФормы,Форма)
	//лАтрибут =	гРасширениеФормы.ДобавитьАтрибутНаФорму(ИмяАтрибута, Тип);
	Если ТипВид = "" Тогда
		лАтрибут =	гРасширениеФормы.ДобавитьАтрибут(ИмяАтрибута, ТипАтрибута);
	Иначе
		лАтрибут =	гРасширениеФормы.ДобавитьАтрибут(ИмяАтрибута, ТипАтрибута, ТипВид);
	КонецЕсли;

	Сообщить("лАтрибут.Идентификатор = <"+лАтрибут.Идентификатор+">"+" "+
		"лАтрибут.Видимость = <"+лАтрибут.Видимость+">"+" "+
		"Форма.НоваяКнопка.Видимость() = <"+Форма.ПолучитьАтрибут(ИмяАтрибута).Видимость()+">");

	//Форма.ПолучитьАтрибут(ИмяАтрибута).НазначитьТип();
	);
	//Форма.ПолучитьАтрибут(ИмяАтрибута).ОбъектЯчейка.Формула = "";

	лАтрибут.Заголовок = ИмяАтрибута;

	Лево = 0;
	Верх = 0;
	Ширина = 0;
	Высота = 0;
	лАтрибут.ПолучитьКоординаты(Лево, Верх, Ширина, Высота);

	Лево = 10 + Смещение;
	Верх = 10 + Смещение;
	Ширина = 80 + Смещение;
	//Высота = 10 + Смещение;
	Высота = 20;
	лАтрибут.УстановитьКоординаты(Лево, Верх, Ширина, Высота);

	Возврат лАтрибут;
КонецФункции            


Процедура ПослеОткрытия(Конт)
	ФормаРасш = СоздатьОбъект("РасширениеФормы");
	ФормаРасш.УстановитьФорму(Конт.Форма);

	Смещение = 10;
	лАтрибут =	ДобавитьАтрибут("НоваяКнопка1", 2, Смещение,"Справочник.Контрагенты",ФормаРасш,Конт.Форма);
	ФормаРасш.Обновить();

	СтрокаФормы=ФормаРасш.ПолныйТипОбъекта();

	Поз=Найти(СтрокаФормы,".");
	Если Поз>0 Тогда
		Объект=Лев(СтрокаФормы,Поз-1);
		Сообщить(Объект);
	КонецЕсли;

	//Сообщить("Открыта форма: "+ФормаРасш.ПолныйТипОбъекта()+" ["+ФормаРасш.ПолныйПуть()+"]");
КонецПроцедуры 

  
Наверх
 
IP записан
 
АЛьФ
FormEx developer
1c++ developer
Отсутствует



Сообщений: 1538
Местоположение: Санкт-Петербург
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Революция - возможность добавления атрибутов!!
Ответ #209 - 07. Мая 2008 :: 07:17
Печать  
Boris_1c писал(а) 07. Мая 2008 :: 06:15:
FormEx 2.0.5.86

новая кнопка - справочник
Код: Сообщить(НоваяКнопка1);

Выдает ошибку
Сообщить(НоваяКнопка1<<?>>);
Переменная не определена (НоваяКнопка1)


Все правильно. Добавляется ведь атрибут формы, а не переменная модуля.
  

FormEx developer
Наверх
www  
IP записан
 
Переключение на Главную Страницу Страницы: 1 ... 12 13 [14] 15 16 ... 18
ОтправитьПечать