Переключение на Главную Страницу Страницы: [1] 2 3 ... 66 ОтправитьПечать
Очень популярная тема (более 25 ответов) Colorer for Openconf - обсуждения (число прочтений - 323538 )
metaeditor
1c++ power user
Отсутствует


are you nuts?

Сообщений: 564
Зарегистрирован: 04. Июля 2006
Пол: Мужской
Colorer for Openconf - обсуждения
20. Февраля 2007 :: 04:37
Печать  
Плагин SciColorer - альтернативный текстовый редактор для конфигуратора 1С на основе компоненты Scintilla

Заменяет встроенный редакторо на более "продвинутый", с множеством функций современной среды разработки:

- Подсветка парных конструкций (скобки, Если ... КонецЕсли и т.п.)
- Свертка процедур, условий, циклов
- Номера строк, закладки
- Подсветка текущей строки, подсветка скобок и кавычек
- и многое другое...


в этой ветке только обсуждения, сам плагин находитсяздесь
« Последняя редакция: 20. Апреля 2008 :: 14:27 - metaeditor »  

Регистр.EAX.СводныйОстаток()
Наверх
 
IP записан
 
metaeditor
1c++ power user
Отсутствует


are you nuts?

Сообщений: 564
Зарегистрирован: 04. Июля 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #1 - 20. Февраля 2007 :: 04:39
Печать  
.
« Последняя редакция: 20. Апреля 2008 :: 14:28 - metaeditor »  

scicolorer_screen.GIF ( 10 KB | Загрузки )
scicolorer_screen.GIF

Регистр.EAX.СводныйОстаток()
Наверх
 
IP записан
 
smile
Junior Member
**
Отсутствует


бррр... ужас...

Сообщений: 50
Зарегистрирован: 23. Мая 2006
Re: Colorer for Openconf
Ответ #2 - 20. Февраля 2007 :: 04:49
Печать  
Попробовал... попробую попользовать....

Но вообще однозначно респект, за еще одну попытку облегчить труд простых 1Сников Улыбка))
  
Наверх
 
IP записан
 
smile
Junior Member
**
Отсутствует


бррр... ужас...

Сообщений: 50
Зарегистрирован: 23. Мая 2006
Re: Colorer for Openconf
Ответ #3 - 20. Февраля 2007 :: 05:08
Печать  
Сразу комментарии и пожелания, чего не хватает:

1) кнопку быстрой свертки и развертки всех процедур
2) свертка

если тогда
конецесли

для цикл
конеццикла

пока цикл
конеццикла

3) свертка комментариев... перед процедурой обычно идут комментарии к этой процедуре (функции) ... если договорится об обозначении этих комментариев например

//начало ПриНачалеРаботыСистемы()
//тра та та тра та та
//мы везем с собой кота
//конец

тоже их сворачивать блоком в

// ПриНачалеРаботыСистемы()





  
Наверх
 
IP записан
 
kuntashov
Full Member
***
Отсутствует


1С:Специалист

Сообщений: 130
Местоположение: Саратов
Зарегистрирован: 13. Июня 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #4 - 20. Февраля 2007 :: 05:14
Печать  
Дима, ну ты блин даешь Улыбка
Респект!
  

С уважением, &&Александр Кунташов&&http://kuntashov.ru/
Наверх
 
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #5 - 20. Февраля 2007 :: 05:22
Печать  
Круто Улыбка
Большущий респект!!

Еще можно добавить на полосу прокрутки кнопки перехода на начало/конец конструкции (Функция/КонецФункции, Проц/КонецПроц, Если/КонецЕсли, Цикл/КонецЦикла)
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
metaeditor
1c++ power user
Отсутствует


are you nuts?

Сообщений: 564
Зарегистрирован: 04. Июля 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #6 - 20. Февраля 2007 :: 06:46
Печать  
Цитата:
smile
1) кнопку быстрой свертки и развертки всех процедур

есть соответствующие макросы в прилагаемом скрипте, можно их повесить на кнопку в тулбар средствами опенконфа

Цитата:

2) свертка 
если тогда
конецесли 

для цикл
конеццикла

полного аналога восьмерке имхо неполучится сделать без подмены самого редактора, свертку если-конецесли итп я несмогу сделать. Свертку комментариев можно попробовать.

Цитата:
artbear
Еще можно добавить на полосу прокрутки кнопки перехода на начало/конец конструкции (Функция/КонецФункции, Проц/КонецПроц, Если/КонецЕсли, Цикл/КонецЦикла) 

на правый скроллбар или на гуттер?

зы, всем респектующим, спасибо Улыбка
  

Регистр.EAX.СводныйОстаток()
Наверх
 
IP записан
 
Phoenix
Senior Member
****
Отсутствует


itpath.ru

Сообщений: 398
Местоположение: Москва
Зарегистрирован: 15. Июня 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #7 - 20. Февраля 2007 :: 06:53
Печать  
Привет Улыбка
хотелось бы еще:
- выделение редактируемой строки
- возможность подсветки определенных пользователем слов (http://www.1cpp.ru/forum/YaBB.pl?num=1168024422/16#16)
- выделяется если и конец если, иначеесли, иначе - нет, хотелось бы Улыбка
- возможность установки/снятия закладки кликом на гуттере
  

Лень двигатель прогресса.&&http://www.itpath.ru&&;
Наверх
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #8 - 20. Февраля 2007 :: 06:56
Печать  
metaeditor писал(а) 20. Февраля 2007 :: 06:46:
Цитата:
artbear
Еще можно добавить на полосу прокрутки кнопки перехода на начало/конец конструкции (Функция/КонецФункции, Проц/КонецПроц, Если/КонецЕсли, Цикл/КонецЦикла)  

на правый скроллбар или на гуттер?

ИМХО на гуттер удобнее, все в одном месте Улыбка
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
metaeditor
1c++ power user
Отсутствует


are you nuts?

Сообщений: 564
Зарегистрирован: 04. Июля 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #9 - 20. Февраля 2007 :: 07:16
Печать  
Цитата:
- выделяется если и конец если, иначеесли, иначе - нет, хотелось бы

Привет, т.е если например курсор на "иначе", то что выделять, "Если" или "КонецЕсли" ?или ещё как?

зы, ветку буду мониторить, все "хотелосьбы" записываются, всё что технически смогу то постепенно сделаю...
  

Регистр.EAX.СводныйОстаток()
Наверх
 
IP записан
 
Phoenix
Senior Member
****
Отсутствует


itpath.ru

Сообщений: 398
Местоположение: Москва
Зарегистрирован: 15. Июня 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #10 - 20. Февраля 2007 :: 07:23
Печать  
ага, чтобы подсвечивались все ветвления. мне например надо часто их выделять, при этом не всегда мне попадается отформатированный код. и бьютифайер не везде стоит Печаль
  

Лень двигатель прогресса.&&http://www.itpath.ru&&;
Наверх
IP записан
 
smile
Junior Member
**
Отсутствует


бррр... ужас...

Сообщений: 50
Зарегистрирован: 23. Мая 2006
Re: Colorer for Openconf
Ответ #11 - 20. Февраля 2007 :: 07:32
Печать  
Скриптик посмотрел. Навесил на шорткат. Удобно...

Если курсор стоит на иначе, то подсвечивать всю ветку полностью

Код
Выбрать все
Если Тогда

ИначеЕсли Тогда

Иначе

КонецЕсли;

 



по идее хорошо бы было, если бы все эти ключевые слова были подсвечены...
  
Наверх
 
IP записан
 
trdm
1c++ power user
qt1l developer
1c++ moderator
Отсутствует



Сообщений: 2342
Местоположение: г. Ростов-на-Дону
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #12 - 20. Февраля 2007 :: 08:56
Печать  
Мощно задвинул!
Афтар, пиши исчо )))
  
Наверх
IP записан
 
Arta
1c++ power user
Отсутствует



Сообщений: 2537
Местоположение: Нижний Новгород
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #13 - 20. Февраля 2007 :: 09:03
Печать  
Молодца! Так держать! Большущее спасибо за сие творение!
  
Наверх
 
IP записан
 
lustin
1c++ power user
Отсутствует


1C *.*, ROR, Java - на
этом остановимся

Сообщений: 907
Местоположение: Москва
Зарегистрирован: 20. Октября 2006
Пол: Мужской
Re: Colorer for Openconf
Ответ #14 - 20. Февраля 2007 :: 09:08
Печать  
Класс... Прощай поиск закрывающей скобки...

А можно ли сворачивать не только конструкции Процедура - КонецПроцедуры
а еще и операторные скобки Если - КонецЕсли, Пока - КонецЦикла (правда где тогда располагать графический элемент управления - места то слева маловато Подмигивание)

А так ВЕЩЬ!!!

  

бизнес-процесс как техническое задание прекрасно, только у бизнеса нет процессов; у бизнеса есть желание выжить
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
Переключение на Главную Страницу Страницы: [1] 2 3 ... 66
ОтправитьПечать