Переключение на Главную Страницу Страницы: 1 ... 16 17 [18]  ОтправитьПечать
Очень популярная тема (более 25 ответов) Революция - возможность добавления атрибутов!! (число прочтений - 151743 )
Eprst
God Member
*****
Отсутствует



Сообщений: 3396
Зарегистрирован: 08. Октября 2007
Re: Революция - возможность добавления атрибутов!!
Ответ #255 - 27. Августа 2013 :: 04:37
Печать  
как бэ не починили, и это не работает..
Улыбка
Не боись, скоро 1с-ина свернётся в трубочку.
  
Наверх
 
IP записан
 
fio
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 3
Зарегистрирован: 08. Мая 2014
Re: Революция - возможность добавления атрибутов!!
Ответ #256 - 08. Мая 2014 :: 10:30
Печать  
[quote author=nicolas link=1178269183/240#254 date=1377544094]Скажите когда починили
[code]РасшФормы.ДобавитьАтрибут("новая колонка", 9,)[/code]
Сегодня проверил, РАБОТАЕТ
108 Formex
[code]
 Процедура Послеоткрытия()
       РасшФормы = СоздатьОбъект("РасширениеФормы");
     РасшФормы.УстановитьФорму(Форма);
     РасшФормы.ПолучитьАтрибут("МногострочнаяЧасть");
     
     лАтрибут =      РасшФормы.ДобавитьАтрибут("Наценка", 9,"Справочник.Банки",5);

     лАтрибут1 =      РасшФормы.ДобавитьАтрибут("Цена новая", 9,"Справочник.Банки",6);

[/code]


СПАСИБО!!!!!
"Справочник.Банки"  -  я от фонаря написал
[/quote]
[code]
Процедура ПослеОткрытия()
     РасширениеФормы=СоздатьОбъект("РасширениеФормы");
     МногострочнаяЧасть=РасширениеФормы.ПолучитьАтрибут("МногострочнаяЧасть");
     РасширениеФормы.ДобавитьАтрибут("FormEx_ПланРаскраски",9);
КонецПроцедуры
[/code]
Криво и непонятно зачем, но работает. В справочнике 3 элемента.
  

Untitled20140508141936.jpg ( 58 KB | Загрузки )
Untitled20140508141936.jpg
Наверх
 
IP записан
 
fio
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 3
Зарегистрирован: 08. Мая 2014
Re: Революция - возможность добавления атрибутов!!
Ответ #257 - 08. Мая 2014 :: 11:57
Печать  
Избавиться от некорректного отображения списка элементов в многострочной части удалось оборачиванием.
  

Untitled20140508154709.jpg ( 60 KB | Загрузки )
Untitled20140508154709.jpg
Наверх
 
IP записан
 
fio
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 3
Зарегистрирован: 08. Мая 2014
Re: Революция - возможность добавления атрибутов!!
Ответ #258 - 08. Мая 2014 :: 12:09
Печать  
Оборачивание

Код
Выбрать все
Перем РасширениеФормы,НеЗакрывать;

Процедура ПриЗакрытии()
	Если ПустоеЗначение(НеЗакрывать)=0 Тогда
		РасширениеФормы.ДобавитьАтрибут("FormEx_ПланРаскраски",9,1,2);
		СтатусВозврата(0);
		НеЗакрывать=0;
		Возврат;
	КонецЕсли;
КонецПроцедуры

Процедура ПослеОткрытия()
	РасширениеФормы=СоздатьОбъект("РасширениеФормы");
	Форма.Закрыть(0);
	НеЗакрывать=1;
КонецПроцедуры
 



Однако даже в этом случае

Код
Выбрать все
РасширениеФормы.ДобавитьАтрибут("FormEx_ПланРаскраски",9);
 



приводит к тому, что кнопки формы (Закрыть, Список, Договоры и т.д.) перестают работать. А хотелось лишь, как вы уже наверное поняли из #256, с минимальным вмешательством в конфигурацию задействовать раскраску таблицы.

Смущённый
  
Наверх
 
IP записан
 
Nick
God Member
*****
Отсутствует



Сообщений: 1599
Местоположение: г.Новокузнецк
Зарегистрирован: 21. Февраля 2007
Пол: Мужской
Re: Революция - возможность добавления атрибутов!!
Ответ #259 - 29. Сентября 2015 :: 15:08
Печать  
Quan писал(а) 24. Сентября 2008 :: 10:52:
Arta писал(а) 04. Мая 2007 :: 10:24:
vip писал(а) 04. Мая 2007 :: 10:21:
Просится теперь метод УдалитьАтрибут(). Возможно такое?


Видимость(0)

Улыбка

Не совсем идентично удалению: неудаленному атрибуту придется делать Видимость(0) при каждом выборе слоя, а про удалённый атрибут можно смело забыть


Для потомков, код:
Элемент.Слой = ""; решает проблему ))))
  
Наверх
ICQ  
IP записан
 
Satans Claws
God Member
*****
Отсутствует


1C++ rocks!

Сообщений: 721
Зарегистрирован: 29. Ноября 2010
Re: Революция - возможность добавления атрибутов!!
Ответ #260 - 09. Октября 2019 :: 02:00
Печать  
У создаваемых программно атрибутов формы есть проблемы с установкой некоторых параметров:

Например,
Код
Выбрать все
	РасшФормы = СоздатьОбъект("РасширениеФормы");
	РасшФормы.УстановитьФорму(Форма);
	Атр = РасшФормы.ДобавитьАтрибут("ВыбЗнач3", 2, "Строка");
	//Сообщить("Ф = <" + Атр.Формула + ">");
	Атр.Маска = "!!!!!!!!";
	//Форма.ВыбЗнач3.Маска("!!!!!!!")
 


маска установлена не будет.
Причем, штатными средствами тоже не изменяется.
Для числа не изменяется параметр "Неотрицательный".

ЗЫ Кстати, этот атрибут ВыбЗнач3, почему-то еще и с формулой "0" создается. Но формула программно меняется нормально.

formex 2.0.5.143
(если важно - 1c++ 3.2.3.16)
  
Наверх
 
IP записан
 
Переключение на Главную Страницу Страницы: 1 ... 16 17 [18] 
ОтправитьПечать