Переключение на Главную Страницу Страницы: 1 ... 77 78 [79]  ОтправитьПечать
Очень популярная тема (более 25 ответов) Класс "ПоставщикДанных" - обсуждения, примеры, вопросы (число прочтений - 316651 )
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы
Ответ #1170 - 25. Сентября 2010 :: 05:18
Печать  
zk96 писал(а) 24. Сентября 2010 :: 13:14:
У меня ничего не изменилось-вылетает. Тест прилагаю. Всего один документ, его нужно открыть-закрыть раз 10-20) и мы вылетаем.
Версия класса ПоставщикДанных = "3.07.001.5 04.08.2010";

Попробовал тест, после нескольких открытий появляется ошибка доступа к какому-нибудь bmp-файлу Печаль
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
zk96
Senior Member
****
Отсутствует


1C++ rocks!

Сообщений: 320
Местоположение: Киев
Зарегистрирован: 15. Ноября 2009
Пол: Мужской
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы
Ответ #1171 - 25. Сентября 2010 :: 07:44
Печать  
artbear писал(а) 25. Сентября 2010 :: 05:18:
...
Попробовал тест, после нескольких открытий появляется ошибка доступа к какому-нибудь bmp-файлу Печаль

Но кроме этого в тексте ошибки "out of memory"
  
Наверх
 
IP записан
 
spock
1c++ developer
1c++ moderator
Отсутствует



Сообщений: 822
Местоположение: Новосибирск
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы
Ответ #1172 - 25. Сентября 2010 :: 13:40
Печать  
Да, течет. На этом тестовом примере (см. вложение) стабильно течет на USER\GDI по 2\6 штук, icpp v3.2.2.6
На 1cpp (моей версии) не течет.
  

_________________IPicture.rar ( 5 KB | Загрузки )
Наверх
ICQ  
IP записан
 
spock
1c++ developer
1c++ moderator
Отсутствует



Сообщений: 822
Местоположение: Новосибирск
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы
Ответ #1173 - 25. Сентября 2010 :: 16:18
Печать  
Прошелся Олей, наткнулся на блок перехватов, в том числе DecrRef... Я так понимаю, в нынешнем виде компоненты следить за счетчиком не надо? Тогда достаточно убрать в файле PicService.cpp в методе CPicService::GetRenderedPicture строчку ppPicture[0]->AddRef();
Ну и сессно досадный ML в конструкторе CPicService.
  
Наверх
ICQ  
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы
Ответ #1174 - 26. Сентября 2010 :: 06:49
Печать  
spock писал(а) 25. Сентября 2010 :: 16:18:
Прошелся Олей, наткнулся на блок перехватов, в том числе DecrRef...

Прошелся "Олей" - это ты про что?
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы
Ответ #1175 - 26. Сентября 2010 :: 08:04
Печать  
spock писал(а) 25. Сентября 2010 :: 16:18:
Прошелся Олей, наткнулся на блок перехватов, в том числе DecrRef... Я так понимаю, в нынешнем виде компоненты следить за счетчиком не надо? Тогда достаточно убрать в файле PicService.cpp в методе CPicService::GetRenderedPicture строчку ppPicture[0]->AddRef();
Ну и сессно досадный ML в конструкторе CPicService.

1. Зарегистрирован баг http://www.1cpp.ru/bugs/show_bug.cgi?id=4504
2. Исправление подтверждаю, утечка на тестовом примере исчезла.
3. Исправление внесено в репозитарий icpp

Выложил версию icpp 3.2.2.7 с исправлением
http://www.1cpp.ru/forum/YaBB.pl?num=1281717242/41#41
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы
Ответ #1176 - 26. Сентября 2010 :: 08:28
Печать  
Артур, большое спасибо тебе Улыбка
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
Antonio
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 14
Зарегистрирован: 20. Января 2010
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы
Ответ #1177 - 26. Сентября 2010 :: 09:17
Печать  
У всех всё в норме? У меня с новой версией при попытке инициализации поставщика данных 1С валится с ошибкой, которую ранее не приходилось встречать:
Ошибка приложения 1cv7s.exe, версия 7.70.0.27, модуль miscr3.dll, версия 7.0.0.124, адрес 0x0000b451.
WinXP SP3, 1C - 7.70.027, dbf
  
Наверх
 
IP записан
 
spock
1c++ developer
1c++ moderator
Отсутствует



Сообщений: 822
Местоположение: Новосибирск
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы
Ответ #1178 - 26. Сентября 2010 :: 13:16
Печать  
artbear писал(а) 26. Сентября 2010 :: 06:49:
spock писал(а) 25. Сентября 2010 :: 16:18:
Прошелся Олей, наткнулся на блок перехватов, в том числе DecrRef...

Прошелся "Олей" - это ты про что?

ollydbg
  
Наверх
ICQ  
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы
Ответ #1179 - 26. Сентября 2010 :: 17:09
Печать  
Дабы не сломать случайно эту ветку предлагаю все обсуждения перенести в продолжение. А именно сюда.
Надеюсь что это сообщение будет тут последним

Итак: ч.2 - http://www.1cpp.ru/forum/YaBB.pl?num=1285520767
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
mirvel
Junior Member
**
Отсутствует


1C++ rocks!

Сообщений: 55
Зарегистрирован: 28. Августа 2010
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы...Неудачна
Ответ #1180 - 16. Марта 2011 :: 06:21
Печать  
Вопрос остался открытым....что делать при выводе сообщения ....
Неудачная попытка создания объекта  КартинкиПанелиУправления = СоздатьОбъект("MSComctlLib.ImageListCtrl");

на XP нормально работает ПоставщикДАнных а вот на машине свежеустановленную SERVER2003 sp1 не работает...при обновлении до sp2...проблема остается...вылазит ошибка...Неудачная попытка создания объекта  КартинкиПанелиУправления = СоздатьОбъект("MSComctlLib.ImageListCtrl");

  • запустил regsvr32.exe vbscript.dll и jvscript.dll

  • обновил server 2003 do sp2

  • поставил уровень безопасности iexplorera на самый низкий уровень...


НЕ ПОМОГАЕТ!!!!

Все Проблема решена после установки Office 2007
  
Наверх
 
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы
Ответ #1181 - 19. Марта 2011 :: 19:29
Печать  
ОБРАТИТЕ ВНИМАНИЕ.
Обсуждение класса ведется в теме по данному адресу:
http://www.1cpp.ru/forum/YaBB.pl?num=1285520767/0

Данная ветка рекомендуется только к просмотру, поскольку есть шанс ее разрушения в следствии разростания.
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
ReEnter58
YaBB Newbies
*
Отсутствует


1C++ rocks!

Сообщений: 13
Зарегистрирован: 25. Марта 2011
Re: Класс "ПоставщикДанных" - обсуждения, примеры, вопросы
Ответ #1182 - 19. Апреля 2011 :: 09:00
Печать  
Если есть реквизит ТЗ хранящийся в строке неограниченной длины, то при использовании ПоставщикаДанных.Документы при копировании эти заполнение ТЗ не происходит, т.к. форма уже открыта. Сделал Дополнительный параметр в ПередНачаломДобавления - флаг вызова процедуры Заполнения.

Процедура СкопироватьСтроку() Экспорт
....
....
Если Информатор.МетодСуществует(КонтекстФормы,ИмяМетода) = 1 Тогда
           .......
           СтруктураПараметров.Установить("ИВП",-1);
           .....
КонецЕсли
....
Если СтруктураПараметров.Получить("ИВП") = 0 Тогда
           КонтФормы.ПослеВсего();
     КонецЕсли;      
     КонтФормы.Форма.Обновить();
КонецПроцедуры



Процедура ТПТКДПередНачаломДобавления(ТП,Копия,ФСО,ИВП)
     Если Копия = 1 Тогда
           ИВП = 0;
     КонецЕсли;      
КонецПроцедуры

Ив модуле документа есть процедура ПослеВсего() которая заполняет ТЗ из строчек неогр. длины.

  
Наверх
 
IP записан
 
Переключение на Главную Страницу Страницы: 1 ... 77 78 [79] 
ОтправитьПечать