Переключение на Главную Страницу Страницы: 1 ... 12 13 [14] 15 16 17 ОтправитьПечать
Очень популярная тема (более 25 ответов) Репозитарий классов 1С++ в единой конфе (число прочтений - 201994 )
mvgfirst
Full Member
***
Отсутствует


В борьбе бобра с ослом
всегда побеждает бобро!

Сообщений: 152
Местоположение: Украина г. Кривой Рог
Зарегистрирован: 17. Августа 2007
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #195 - 22. Августа 2007 :: 18:37
Печать  
Как это не удивительно, но после того как я обновил FormEx и 1С++ обработка с выбором значений заработала.
Но перестал работать Пример_РедактированиеТЗ.ert после того как закомментировал "ВключитьПерехватСобытий" частично заработало.. но с ошибками.. элементы редактирования появляются но значения не сохраняются...

Устал уже ... боротся... скажите плиз что не так....
Мне как раз надо обе этих фичи использовать одновременно Улыбка... и редактировать ТЗ и использовать выбор значений по частичному вводу аля 1с80
  
Наверх
ICQ  
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #196 - 23. Августа 2007 :: 10:07
Печать  
Баг описан вот здесь
http://www.1cpp.ru/forum/YaBB.pl?num=1187702961
Ищу способ решения.
Пока могу сказать, что
1) универсально не получится
2) но можно скомпоновать указанный набор классов так, чтобы они знали друг о друге, и соответственно события не пропадали.
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
sergiowood
YaBB Newbies
*
Отсутствует


I Love YaBB 2!

Сообщений: 2
Зарегистрирован: 04. Октября 2007
Re: Репозитарий классов 1С++ в единой конфе
Ответ #197 - 04. Октября 2007 :: 10:31
Печать  
Если не жалко, бросьте последний вариант конфы для "Репозитарий классов 1С++ в единой конфе" или подскажите, где можно качнуть. По ссылкам на форуме конфы нет. Помогите чем можете.
  
Наверх
 
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #198 - 04. Октября 2007 :: 11:26
Печать  
Читай самый первый пост.
Там указана основная ссылка, по которой ВСЕГДА лежит конфа и ее обновления.
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
sergiowood
YaBB Newbies
*
Отсутствует


I Love YaBB 2!

Сообщений: 2
Зарегистрирован: 04. Октября 2007
Re: Репозитарий классов 1С++ в единой конфе
Ответ #199 - 04. Октября 2007 :: 11:47
Печать  
Огромное спасибо.
  
Наверх
 
IP записан
 
Nick
God Member
*****
Отсутствует



Сообщений: 1599
Местоположение: г.Новокузнецк
Зарегистрирован: 21. Февраля 2007
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #200 - 09. Ноября 2007 :: 08:37
Печать  
Артур, подскажи в чём может быть проблема:
1. Скачал конфу с классами, разархивировал
2. В конфигураторе при открытии дерева конфигурации выдает ошибку:

"Не удалось пролчитать файл ...\ОБЩИЕКЛАССЫ\DEFCLS.PRM
В модуле DEFCLS@MD
Ошибка в дериктиве include
(3) //#include ОбщиеКлассы\defcls.prm"

файлы существуют

  
Наверх
ICQ  
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #201 - 09. Ноября 2007 :: 08:52
Печать  
Nick писал(а) 09. Ноября 2007 :: 08:37:
Артур, подскажи в чём может быть проблема:
1. Скачал конфу с классами, разархивировал
2. В конфигураторе при открытии дерева конфигурации выдает ошибку:

"Не удалось пролчитать файл ...\ОБЩИЕКЛАССЫ\DEFCLS.PRM
В модуле DEFCLS@MD
Ошибка в дериктиве include
(3) //#include ОбщиеКлассы\defcls.prm"

файлы существуют

В режиме Предприятия все ок?
Если да, тогда 100% у тебя старый плагин Визуал1С++ в папке Бин\Конфиг\vis1cpp.dll
Юзай новый 1.0.0.13 Улыбка

Если в режиме Предприятия также косяк, тогда проверяй версию 1С++ Улыбка должна быть 2.5
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
Nick
God Member
*****
Отсутствует



Сообщений: 1599
Местоположение: г.Новокузнецк
Зарегистрирован: 21. Февраля 2007
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #202 - 09. Ноября 2007 :: 09:10
Печать  
artbear писал(а) 09. Ноября 2007 :: 08:52:
Nick писал(а) 09. Ноября 2007 :: 08:37:
Артур, подскажи в чём может быть проблема:
1. Скачал конфу с классами, разархивировал
2. В конфигураторе при открытии дерева конфигурации выдает ошибку:

"Не удалось пролчитать файл ...\ОБЩИЕКЛАССЫ\DEFCLS.PRM
В модуле DEFCLS@MD
Ошибка в дериктиве include
(3) //#include ОбщиеКлассы\defcls.prm"

файлы существуют

В режиме Предприятия все ок?
Если да, тогда 100% у тебя старый плагин Визуал1С++ в папке Бин\Конфиг\vis1cpp.dll
Юзай новый 1.0.0.13 Улыбка

Если в режиме Предприятия также косяк, тогда проверяй версию 1С++ Улыбка должна быть 2.5


Спасибо!
Была старая версия Визуал1с++
  
Наверх
ICQ  
IP записан
 
Nick
God Member
*****
Отсутствует



Сообщений: 1599
Местоположение: г.Новокузнецк
Зарегистрирован: 21. Февраля 2007
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #203 - 09. Ноября 2007 :: 11:07
Печать  
Артур вопрос видимо уже не к тебе но может знаешь куда копать:

После установке последнего Vis1pp в Colorer начисто пропала латиница т.е включаешь
английскую расклатку и всё - буквы не печатаются, переключаешся на рускую всё ОК
  
Наверх
ICQ  
IP записан
 
SiriuS
Junior Member
**
Отсутствует



Сообщений: 87
Зарегистрирован: 16. Февраля 2007
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #204 - 20. Ноября 2007 :: 14:20
Печать  
artbear писал(а) 02. Апреля 2007 :: 06:30:
С помощью данного механизма показано, как с минимумом измененений конфигурации (только в глобальнике три строчки) можно выполнять различные действия для любых открываемых форм -
1) замена формул на лету (класс Общие.ВыборПериода)


Вопрос а как избавиться от надписи
"Дocтyп к фaйлy  BыбopПepиoдa.ert зaкpыт"

Т.е. как я понимаю самое простое это переделать класс Общие.ВыборПериода чтоб весь этот функционал находился внутри MD-ка .....
и еще..... как избавиться от эффекта двойного нажатия по форме обработки ....
Или это у меня тока такое проявляеться....
Ну и на последок, если два раза нажать на кнопку выбора периода с секундной задеркой то вылезет стандартное окно выбора периода..... эта такая фича или это баг

P.S. Проверялось все на новай базе, версия 1C++ v:2.5.0.3
  
Наверх
 
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #205 - 20. Ноября 2007 :: 15:01
Печать  
Цитата:
Вопрос а как избавиться от надписи
"Дocтyп к фaйлy  BыбopПepиoдa.ert зaкpыт"

Т.е. как я понимаю самое простое это переделать класс Общие.ВыборПериода чтоб весь этот функционал находился внутри MD-ка .....
и еще..... как избавиться от эффекта двойного нажатия по форме обработки ....
Или это у меня тока такое проявляеться....
Ну и на последок, если два раза нажать на кнопку выбора периода с секундной задеркой то вылезет стандартное окно выбора периода..... эта такая фича или это баг

1. Да, тогда тебе нужно закинуть в МД
2. Эффект двойного нажатия? Вроде я его устранил, давай подробнее Улыбка
3. нужно проверить Улыбка
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
SiriuS
Junior Member
**
Отсутствует



Сообщений: 87
Зарегистрирован: 16. Февраля 2007
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #206 - 20. Ноября 2007 :: 17:55
Печать  
Мда начну сначал:
Я пытаюсь прикрутить class Общие.ВыборПериода к своей конфе

На пустой конфе делаю так:
1 в глобальнике гружу 1cpp.dll , RWidjets.dll
2 присоединяю данный класс
3 в глобальнике пишу такую процедуру
Код
Выбрать все
Процедура ПриПолученииКоманды(пКоманда, пЗаблокироватьКоманду)
	Если пКоманда = 32881 Тогда
		Конт = "";
		Если Сервис.АктивныйКонтекст(Конт) = 0 Тогда
			Сообщить("Неудачаа активный контекст = ");
			Возврат;
		КонецЕсли;
		Если ПустоеЗначение(Конт) = 1 Тогда
			Сообщить("Пустой активный контекст = ");
			Возврат;
		КонецЕсли;
		РасширениеФормы = СоздатьОбъект("РасширениеФормы");
		РасширениеФормы.УстановитьФорму(Конт.Форма);
		Если РасширениеФормы.ТипОбъекта() = "Журнал" Тогда
			лВыборПериода = СоздатьОбъект("Общие.ВыборПериода");
			ДатаНачала = Конт.НачалоИнтервала(); //'01.05.1995';
			ДатаОкончания = Конт.КонецИнтервала(); //'25.05.2007';
			Если лВыборПериода.ВвестиПериод(ДатаНачала, ДатаОкончания, "Выберите интервал журнала") = 1 Тогда
				// в этот момент идет повторная отправка команды 32881, от чего и защитились
				Конт.УстановитьИнтервал(ДатаНачала, ДатаОкончания);
				пЗаблокироватьКоманду = 1;
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры 


4 проверяю как все это работает на общем журнале

..... В итоге обноружил следующие глюки:
1. Если нажать на кнопку "Интервал", дождаться когда появиться "наше" окно "Выбор периода" то можно спакойно нажать на любую кнопку панели инструментов журнала, даже если и новая форма перекрывает их
2. Двойной клик в форме чтобы нажать на любой элемент "нашей" формы.
Опытным путем установленно, что тока после первого клика форма начинает принимать какие-то сообщения или реагировать на мыш.... (мож она не до конца проинициирована или ее хедер не зарегистрирован чтоб получать сообщения)
Вот скриншоты:



P.S. Самое интересное в том что когда все это дело делаеш под отладчиком пошагово все ГУД....
  
Наверх
 
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #207 - 21. Ноября 2007 :: 06:44
Печать  
Так бы сразу и сказал Улыбка
C перехватом интервала через РВиджетс или ФормЕкс у меня ничего так и не получилось Печаль
Пробовал не один раз Печаль
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
SiriuS
Junior Member
**
Отсутствует



Сообщений: 87
Зарегистрирован: 16. Февраля 2007
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #208 - 21. Ноября 2007 :: 20:15
Печать  
artbear писал(а) 21. Ноября 2007 :: 06:44:
Так бы сразу и сказал Улыбка
C перехватом интервала через РВиджетс или ФормЕкс у меня ничего так и не получилось Печаль
Пробовал не один раз Печаль


.... Мда от данного глюка частично спасает тока такой код в модуле обработки ВыборПериода.ert ......
Код
Выбрать все
Процедура ПослеОткрытия()
	Предупреждение("",1);
КонецПроцедуры 


... буду капать дальше может и более элегантное решение найдеться  
  
Наверх
 
IP записан
 
leshik
1c++ donor
Отсутствует



Сообщений: 820
Местоположение: Пятигорск
Зарегистрирован: 22. Апреля 2007
Пол: Мужской
Re: Репозитарий классов 1С++ в единой конфе
Ответ #209 - 06. Декабря 2007 :: 09:21
Печать  
Артур, прошу Вас исправить в классе Общие.Форма.Привязка ошибку описанную здесь:
http://www.1cpp.ru/forum/YaBB.pl?num=1178868866/1#1
Строка 396 -
заменить:
Код
Выбрать все
Курсор=0; 


на
Код
Выбрать все
Курсор=-1; 


Заранее спасибо!
  
Наверх
IP записан
 
Переключение на Главную Страницу Страницы: 1 ... 12 13 [14] 15 16 17
ОтправитьПечать