Переключение на Главную Страницу Страницы: 1 [2] 3 4 ... 81 ОтправитьПечать
Очень популярная тема (более 25 ответов) Класс "ПоставщикДанных" - обсуждения. Часть 2. (число прочтений - 364677 )
dimm73
Senior Member
****
Отсутствует


I Love YaBB 2!

Сообщений: 414
Зарегистрирован: 03. Июля 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #15 - 07. Октября 2010 :: 12:45
Печать  

Код
Выбрать все
Процедура ТабличноеПолеМногострочнойЧастиПередПроведением(ТабличноеПоле,ФСО)
	//ТабличноеПоле.ОбновитьСтрокиТабличногоПоля();
	ПоставщикДанных.Обновить();
КонецПроцедуры
 



проверил в отладчике -  это событие не отрабатывает (в него не заходит)
  
Наверх
 
IP записан
 
dimm73
Senior Member
****
Отсутствует


I Love YaBB 2!

Сообщений: 414
Зарегистрирован: 03. Июля 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #16 - 11. Октября 2010 :: 05:17
Печать  
Прошу ответить разработчика. Нужна помощь
  
Наверх
 
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #17 - 11. Октября 2010 :: 08:08
Печать  
В общем я счас решил пока так:
1. Переменная глобального модуля: МенеджерСобытийПриЗаписиДокумента. Объект "МенеджерСобытий" из 1С++.
2. Все документы в процедуре "ПриЗаписи" посылают события через него.
3. Все журналы подписываются в данном менеджере, проверяют свои виды на вхождение и соответственно вызываются обновления табличного поля. (ОбновитьСтроки). "ПриЗакрытии" подписчик удаляется.
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #18 - 11. Октября 2010 :: 09:27
Печать  
В общем все глобальные изменения в поставщике данных окончены. Сейчас все изменения будут задокументированы, также будет добавлена документация по новым объектам. Начинается период тестирования и переноса на мою боевую базу, после чего выложу обновление вполне официально.
В общем не буду загадывать, но планирую 3.7.1 выложить на этой неделе.
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
dimm73
Senior Member
****
Отсутствует


I Love YaBB 2!

Сообщений: 414
Зарегистрирован: 03. Июля 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #19 - 11. Октября 2010 :: 09:32
Печать  
vandalsvq писал(а) 11. Октября 2010 :: 08:08:
В общем я счас решил пока так:
1. Переменная глобального модуля: МенеджерСобытийПриЗаписиДокумента. Объект "МенеджерСобытий" из 1С++.
2. Все документы в процедуре "ПриЗаписи" посылают события через него.
3. Все журналы подписываются в данном менеджере, проверяют свои виды на вхождение и соответственно вызываются обновления табличного поля. (ОбновитьСтроки). "ПриЗакрытии" подписчик удаляется.



Если можно подробнее

п.1 Добавил в глобальный модуль переменную МенеджерСобытийПриЗаписиДокумента

п.2. В ПриЗаписи() нужного документа

МенеджерСобытийПриЗаписиДокумента =1

п.3 ???
здесь подробнее , сходу не понял
  
Наверх
 
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #20 - 11. Октября 2010 :: 09:55
Печать  
В глобальном модуле:

Код
Выбрать все
Перем МенеджерСобытийПриЗаписи Экспорт;

Процедура ПриНачалеРаботыСистемы()
    /// после загрузки компонент
    МенеджерСобытийПриЗаписи = СоздатьОбъект("МенеджерСобытий");
КонецПроцедуры 



В документе:
Код
Выбрать все
Процедура ПриЗаписи()
    ФСО = 1;
    МенеджерСобытийПриЗаписи.ПослатьСобытие(Вид(),ФСО);
    Если ФСО = 0 Тогда
	  СтатусВозврата(0);
	  Возврат;
    КонецЕсли;
КонецПроцедуры 



В обработке где находится журнал документов (поставщик данных Журнал или Документ)

Код
Выбрать все
Процедура ПриОткрытии()
   иЗаписиДокумента");
КонецПроцедуры

Функция ИдентификаторТППриЗаписиДокумента(ВидДокумента,ФСО)
    Если ПустоеЗначение(ПоставщикДанных) = 1 Тогда
	  Возврат;
    КонецЕсли;
    Если СписокВидовДокументов.НайтиЗначение(ВидДокумента) = 0 Тогда
	  Возврат;
    КонецЕсли;
    ПоставщикДанных.ТабличноеПоле.ОбновитьСтроки();
КонецФункции 



Проверь названия методов у объекта "МенеджерСобытий" в соответствии с документацией. Вдруг напутал.
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
dimm73
Senior Member
****
Отсутствует


I Love YaBB 2!

Сообщений: 414
Зарегистрирован: 03. Июля 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #21 - 11. Октября 2010 :: 10:02
Печать  
Перем МенеджерСобытийПриЗаписи;

эта переменная не экспортная?
  
Наверх
 
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #22 - 11. Октября 2010 :: 10:08
Печать  
dimm73 писал(а) 11. Октября 2010 :: 10:02:
Перем МенеджерСобытийПриЗаписи;

эта переменная не экспортная?

Экспортная, исправился. Писал на память не копируя из конфы Улыбка.
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
dimm73
Senior Member
****
Отсутствует


I Love YaBB 2!

Сообщений: 414
Зарегистрирован: 03. Июля 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #23 - 11. Октября 2010 :: 10:13
Печать  
СписокВидовДокументов - не определена, выдает ошибку
  
Наверх
 
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #24 - 11. Октября 2010 :: 10:22
Печать  
Ну конечно, это переменная которая хранит список идентификаторов видов документов, я ее сам создавал Улыбка. Так что либо удали (но тогда будет срабатывать на все доки кто вызвал, независимо от журнала), либо создай и заполни сам по метаданным
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
dimm73
Senior Member
****
Отсутствует


I Love YaBB 2!

Сообщений: 414
Зарегистрирован: 03. Июля 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #25 - 11. Октября 2010 :: 10:24
Печать  
Еще вопрос:

зачем в документе в ПриЗаписи код
Код
Выбрать все
	Если ФСО = 0 Тогда
		СтатусВозврата(0);
		Возврат;
	КонецЕсли;
 



Ведь документ в любом случае должен быть проведен ?
  
Наверх
 
IP записан
 
dimm73
Senior Member
****
Отсутствует


I Love YaBB 2!

Сообщений: 414
Зарегистрирован: 03. Июля 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #26 - 11. Октября 2010 :: 10:31
Печать  
Класссс !!!!!

Спасибо большое  Очень довольный



В предыдущем посте вопрос еще актуален
  
Наверх
 
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #27 - 11. Октября 2010 :: 13:01
Печать  
У меня в подписчике не только обработка обновлений, но и проверка разных реквизитов и т.п. Улыбка
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
pvase
God Member
*****
Отсутствует



Сообщений: 923
Местоположение: Киев
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #28 - 12. Октября 2010 :: 05:48
Печать  
Подскажите пожалуйста как реализован вывод изображения корня дерева в ДеревоЗначений. А еще лучше ткните в коде где это, а то что то не могу найти. Спасибо.
  
Наверх
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "ПоставщикДанных" -обсуждения. Часть 2.
Ответ #29 - 12. Октября 2010 :: 07:50
Печать  
Реализовано при помощи СистемнойКартинки. Код смотреть надо в ПоставщикДанных.ДеревоЗначений в событие ПриВыводеСтроки
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
Переключение на Главную Страницу Страницы: 1 [2] 3 4 ... 81
ОтправитьПечать