Переключение на Главную Страницу Страницы: 1 [2] 3 4 ... 6 ОтправитьПечать
Очень популярная тема (более 25 ответов) Класс "УправлениеФормой" (число прочтений - 38458 )
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #15 - 15. Июля 2010 :: 10:56
Печать  
Выложил обновление:
2.01.002 от 15.07.10 г.
- Исправлена ошибка класс «Коллекция». Не уничтожался из-за наличия внутренних ссылок.
- Исправлена ошибка привязки при открытии максимизированной формы со сплиттерами.

Собственно попытка исправить поведение максимизированной формы.
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
Andrey (sttt)
Junior Member
**
Отсутствует


1C++ rocks!

Сообщений: 49
Зарегистрирован: 10. Января 2009
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #16 - 06. Сентября 2010 :: 12:48
Печать  
начало диалога:
http://www.1cpp.ru/forum/YaBB.pl?num=1283760571/0#0

собственно ничего особенного:

Код
Выбрать все
Перем УправлениеФормой;
Перем Привязка;

Процедура УстановитьПривязки()
	ЭлементПривязки = Привязка.Получить("РамкаШапка");
	ЭлементПривязки.Установить("Верх","В","Форма");
	ЭлементПривязки.Установить("Низ","В","РамкаШапка1");
	ЭлементПривязки.Установить("Лево","Л","Форма");
	ЭлементПривязки.Установить("Право","П","Форма");

        Привязка.Привязать();
КонецПроцедуры

Процедура ДобавитьЭлементыПривязки()
	Привязка = УправлениеФормой.ПривязкаЭлементов;
	Привязка.Добавить("РамкаШапка");
КонецПроцедуры

Процедура ПриОткрытии()
        Загрузить1cpp();
        ЗагрузитьFormEx();

	УправлениеФормой = СоздатьОбъект("УправлениеФормой");
	ДобавитьЭлементыПривязки();
КонецПроцедуры

Процедура ПриИзмененииРазмераОкна()
	УстановитьПривязки();
КонецПроцедуры

Процедура ПослеОткрытияФормы()
	УстановитьПривязки();
КонецПроцедуры 



не желает работать при первом запуске.

и еще интересует, как можно пропорции задать?
Этого недостаточно:
Код
Выбрать все
ЭлементПривязки.Установить("Низ","В","РамкаШапка1"); 

  
Наверх
 
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #17 - 06. Сентября 2010 :: 13:32
Печать  
Собственно есть некоторые ошибки:

Код
Выбрать все
Перем УправлениеФормой;
Перем Привязка;

Процедура УстановитьПривязки()
	ЭлементПривязки = Привязка.Получить("РамкаШапка");
	//ЭлементПривязки.Установить("Верх","В","Форма"); // привязка по умолчанию есть
	ЭлементПривязки.Установить("Низ","В","РамкаШапка1");
	//ЭлементПривязки.Установить("Лево","Л","Форма"); // аналогично верху
	ЭлементПривязки.Установить("Право","П","Форма");

	  Привязка.Привязать();
КонецПроцедуры

Процедура ДобавитьЭлементыПривязки()
	Привязка = УправлениеФормой.ПривязкаЭлементов;
	Привязка.Добавить("РамкаШапка");
КонецПроцедуры

Процедура ПриОткрытии()
	  Загрузить1cpp();
	  ЗагрузитьFormEx();

	УправлениеФормой = СоздатьОбъект("УправлениеФормой");
	ДобавитьЭлементыПривязки();
	УстановитьПривязки();
КонецПроцедуры 


Собственно если не работает то надо смотреть включен ли EnableTurboBL, загрузку ВК вообще следует делать в глобальнике ибо это не гуд. В остальном проблем не должно быть если не используешь перехватчик.
Перепривязывать элементы не нужно при изменениях. Он (класс) сам умеет все делать как надо.

Пы.сы. а с пропорциями класс не умеет работать.
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
Andrey (sttt)
Junior Member
**
Отсутствует


1C++ rocks!

Сообщений: 49
Зарегистрирован: 10. Января 2009
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #18 - 06. Сентября 2010 :: 14:00
Печать  
vandalsvq писал(а) 06. Сентября 2010 :: 13:32:
Собственно есть некоторые ошибки:
...
Собственно если не работает то надо смотреть включен ли EnableTurboBL, загрузку ВК вообще следует делать в глобальнике ибо это не гуд. В остальном проблем не должно быть если не используешь перехватчик.
Перепривязывать элементы не нужно при изменениях. Он (класс) сам умеет все делать как надо.

Пы.сы. а с пропорциями класс не умеет работать.


ошибки: ну, стоило ожидать :0) буду знать. особо не вникал в класс.
перехватчик: перехватчик не использую
Перепривязывать:  упс! а как нужно? т.е. Привязка.Привязать() так я пере привязываю?
  
Наверх
 
IP записан
 
Andrey (sttt)
Junior Member
**
Отсутствует


1C++ rocks!

Сообщений: 49
Зарегистрирован: 10. Января 2009
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #19 - 06. Сентября 2010 :: 14:11
Печать  
к сожалению не помогло включение:

Код
Выбрать все
			УправлениеНастройками = СоздатьОбъект("УправлениеНастройками");
			УправлениеНастройками.Включить("EnableTurboBL"); 



скорее всего лечиться загрузкой dll глобальным модулем
  
Наверх
 
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #20 - 06. Сентября 2010 :: 14:24
Печать  
Привязка.Привязать() вызывается один раз сразу после указания всех настроек. Больше в принципе вообще телодвижений не нужно.
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
Eprst
God Member
*****
Отсутствует



Сообщений: 3397
Зарегистрирован: 08. Октября 2007
Re: Класс "УправлениеФормой"
Ответ #21 - 07. Сентября 2010 :: 14:19
Печать  
Посмотрел класс, так и не понял, зачем в классе УправлениеФормой описана куча событий от перехватчика, которые никогда вызываться не будут (а некоторые, еще и с неправильным синтаксисом - недостаточно параметров), да и описать нужно было только используемые... нипанятна.


  
Наверх
 
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #22 - 07. Сентября 2010 :: 17:49
Печать  
Eprst писал(а) 07. Сентября 2010 :: 14:19:
Посмотрел класс, так и не понял, зачем в классе УправлениеФормой описана куча событий от перехватчика, которые никогда вызываться не будут (а некоторые, еще и с неправильным синтаксисом - недостаточно параметров), да и описать нужно было только используемые... нипанятна.

Прошу указать все ошибки Подмигивание. А остальное "на всякий случай" %)
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
viddik
Junior Member
**
Отсутствует



Сообщений: 37
Зарегистрирован: 22. Октября 2008
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #23 - 08. Сентября 2010 :: 02:29
Печать  
Слетают привязки при использовании на форме ПоставщикаДанных, после метода Обновить()... Это с последним поставщиком, с версией 3.04 такого не происходит.
  
Наверх
 
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #24 - 08. Сентября 2010 :: 03:51
Печать  
viddik писал(а) 08. Сентября 2010 :: 02:29:
Слетают привязки при использовании на форме ПоставщикаДанных, после метода Обновить()... Это с последним поставщиком, с версией 3.04 такого не происходит.


У меня не слетают. И объективных причин такому поведению я не знаю Печаль.
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
Eprst
God Member
*****
Отсутствует



Сообщений: 3397
Зарегистрирован: 08. Октября 2007
Re: Класс "УправлениеФормой"
Ответ #25 - 08. Сентября 2010 :: 05:03
Печать  
vandalsvq писал(а) 07. Сентября 2010 :: 17:49:
Прошу указать все ошибки Подмигивание. А остальное "на всякий случай" %)


В данном классе, никогда не будет событий
Событие_ВводНового(),Событие_ВводНаОсновании() и т.д
+ в событии ВВодНового есть параметры + возвращать нужно тоже разные параметры в этом методе, в зависимости от типа контекста - для документа/справочника одно, для отчета - другое.
Да и зачем описывать остальные события - тоже нипанятна, они же нигде не используются потом.
Эта ошибка вылезет, если перехватывать глоб.модуль и оттуда перехватывать локальные события, когда работать будут все события формы - создание контекста, вводнового, приОткрытии и т.д.
У тебя же этих событий никогда не будет - ты инициализацию класса привязок делаешь уже в созданной форме, в ПриОткрытии.

  
Наверх
 
IP записан
 
vandalsvq
1c++ power user
Отсутствует


Я всего лишь als-особиратель
;-)

Сообщений: 2487
Местоположение: Уфа
Зарегистрирован: 18. Июля 2007
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #26 - 08. Сентября 2010 :: 05:57
Печать  
Согласен. Спасибо за наводку.
  

Отхожу от дел. Долго и мучительно.
Наверх
IP записан
 
artbear
1c++ developer
1c++ moderator
Отсутствует


Эх, дайте что-нибудь новенькое
да полезное потести

Сообщений: 6303
Местоположение: Москва
Зарегистрирован: 19. Мая 2006
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #27 - 08. Сентября 2010 :: 12:45
Печать  
Andrey (sttt) писал(а) 06. Сентября 2010 :: 14:00:
vandalsvq писал(а) 06. Сентября 2010 :: 13:32:
Собственно есть некоторые ошибки:
загрузку ВК вообще следует делать в глобальнике ибо это не гуд.


http://www.1cpp.ru/forum/YaBB.pl?num=1157706754/4#4
Рекомендация по загрузке 1С++ из внешней обработки, если 1С++ не загружена в глобальном модуле
  

OpenConf developer :: http://openconf.1cpp.ru&&FormEx developer :: http://formex.dorex.ru&&1C++ active developer && tester :: www.1cpp.ru
Наверх
GTalkSkype/VoIPICQ  
IP записан
 
Amel
Junior Member
**
Отсутствует


1С++ rulezzz!

Сообщений: 85
Местоположение: Украина, Винница
Зарегистрирован: 20. Ноября 2007
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #28 - 06. Октября 2010 :: 09:50
Печать  
Наблюдаю проблему: при использовании закладок и ПоставщикаДанных с командной панелью и с закладками на форме - панель кнопок перекрывается табличным полем.
  

_________.png ( 5 KB | Загрузки )
_________.png

Восторгаюсь 1С++ и классами к ней!
Наверх
ICQ  
IP записан
 
Amel
Junior Member
**
Отсутствует


1С++ rulezzz!

Сообщений: 85
Местоположение: Украина, Винница
Зарегистрирован: 20. Ноября 2007
Пол: Мужской
Re: Класс "УправлениеФормой"
Ответ #29 - 06. Октября 2010 :: 10:27
Печать  
вот демо-обработка.
  

_____003.ert ( 67 KB | Загрузки )

Восторгаюсь 1С++ и классами к ней!
Наверх
ICQ  
IP записан
 
Переключение на Главную Страницу Страницы: 1 [2] 3 4 ... 6
ОтправитьПечать